Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,290 Members 46,529 Now Online
XDA Developers Android and Mobile Development Forum

[ROM]4.1.2|KING-KANG|Monster One| Spen Gestures (yes fully secure screenshot works)

Tip us?
(Last edited by kimocal; 20th December 2012 at 05:59 PM.) Reason: LOG CAT attached
kimocal's Avatar
Senior Member
Thanks Meter 97
Posts: 414
Join Date: Jul 2006
Location: Cool, CA
Originally Posted by bsc7080xsc View Post

- 66.NODNF
I just started having this issue recently and now it's gotten to the point where right after I reboot the phone I get that FC error right away. Here is what I've tried:
  • clearing the cache/data for the Phone app, restart phone - Still have the FC error.
  • wipe system & dalvik cache in Recovery, Fix Pemissions - Still have the FC error.
  • NANDROID backup current ROM state then just re-install King Kang M1 over existing KK M1 ROM, wipe cache/dalvik, Fix Permissions - Still have the FC error. I can make a call but get the FC right after I hang up. I get the FC immediately when receiving a call.

Looks like I'll have to clean flash the ROM after wiping system. It's been awhile since I've flashed a ROM so I guess my phone is telling me it needs it flashing fix.


I've linked my LOG CAT I made the other day. I started recording, received a call, got the FC, then stopped recording. Any body have any idea of what to look for? This is new territory for me.

http://santangelo-eng/android/callissue.txt 1.2 MB
Nexus 5
hermes2xgreat's Avatar
Senior Member
Thanks Meter 55
Posts: 402
Join Date: Oct 2012
Location: Nagoya
Hands down my favorite Rom.
Thanks Meter 2
Posts: 72
Join Date: Mar 2011
Loving the rom but I've ran into some problems.
Gmail - shows i have new mail but i can not see them in my inbox
Google music - Had to install and reinstall to get it work
Anipang,Dragonfly - Only two games I play and they both makes phone random reboot.
jasonstackhouse's Avatar
Recognized Themer
Thanks Meter 463
Posts: 218
Join Date: Aug 2012
Location: Philadelphia

Default Re: [ROM]4.1.2|KING-KANG|Monster One| Spen Gestures (yes fully secure screenshot work

Boss ROM, I have actively passed on this due to the spen gestures not working until I saw that I didn't read the instructions on the first page. So big bump, only ROM for this phone with almost stock capability. ROM also has been a breeze to mod, look for a full set of theme mods on top of the ROMs already amazing self installed mods

Sent from my SGH-I717 using xda app-developers app
Thanks Meter 4
Posts: 31
Join Date: Nov 2010
Default Activity Media Storage Isn't Responding (And it's driving me mad)

I am at my wit’s end searching for information, but I keep coming up empty.

I want to return to this ROM, but it (and about every other) JB ROM has an issue where audio does not work when it first boots up. Whenever an alarm, alert, or ringtone should play the program will freeze and, eventually, an error will pop up to tell me that “Activity Media Storage Isn’t Responding” with options to Close or Wait. Closing immediately fixes the problem until the next reboot.

Has anyone had this problem? Does anyone know a solution? If there is no proper fix, might there be a script that can get the issue out of the way each boot? (Like asking it to immediately play an alarm on bootup, which is what I usually do to workaround the problem.)

I am profusely grateful for any information or help anyone can offer. I want to get back to King Kang, I want to enjoy Jelly Bean, and I’d love not to miss calls/alarms. Thank you in advance, and I beg pardon if somehow my searching missed something along the way.

armyboy11b's Avatar
Senior Member
Thanks Meter 953
Posts: 2,501
Join Date: Feb 2012
Location: new orleans
Default Re: [ROM]4.1.2|KING-KANG|Monster One| Spen Gestures (yes fully secure screenshot work

Newb.. never had such a problem

Sent from my SAMSUNG-SGH-I717 using xda premium
*Galaxy note i717
Rom-black+star v3
*Nexus 7 tab (shipping)
The Following User Says Thank You to armyboy11b For This Useful Post: [ Click to Expand ]
Thanks Meter 4
Posts: 31
Join Date: Nov 2010
Default Solving Problems

Alright, I have solved the problem, and in case anyone else should run into it, well, this may be your solution.

First, to better define the problem: mp3’s in any folder on internal or external memory card would not work when set as a ringtone or alarm regardless of how it was set. Whenever the alarm/ringtone was called upon the system (specifically the app that called up the sound to play) would freeze and eventually pop up an error reading “Activity Media Storage Isn’t Responding”, which upon force closing would then work properly.

Now, various fixes did not work. Moving the mp3 to particular folders on internal or external memory did not work, for instance. Upon searching, it was mentioned on another Samsung model that this problem was related to the mp3 format and may be fixed by using the .ogg format. This alone did not fix it. Instead, the following process is what I did to fix it.

1) Convert the mp3 to ogg using whatever means you prefer.
2) Move the file into the root directory /system/media/ringtone or /system/media/alarm (/notification for notification). [Caveat: Using Solid Explorer to copy/paste the file did not work for me; it would say it copied, but the file wouldn’t work proper. Root Explorer, however, worked flawlessly. Remember to Mount R/W first!]
3) Change Permissions of the audio file. Permissions should be as follows:
Owner: Read, Write
Group: Read
Others: Read

4) Now, go to Settings in your ROM, find Apps, and track down Media Storage, choose “Clear Data”

5) Reboot and wait a couple minutes for things to repopulate.

6) When setting the alarm/ringtone, choose to pick the audio file via Media Storage, and your ogg file should be there. Voila. All should be well; the problem is fixed.

Now, does it have to be an ogg? I am not so sure, I took the ogg advice before tinkering myself and I didn’t try it with the mp3. Experimentation is how Newbie’s learn, you know, so go for it.

Admittedly, I did not Fix Permissions in Recovery this time, but I am certain I did in previous attempts to fix the problem. However, this is always a good first step.

Now, it seems I am the only one who had this problem, and I haven’t a clue why. If anyone has insight on that, well, I am happy to hear it because I’m quite curious about it. And in the off chance that someone, somewhere runs into this problem, on this phone or ROM or any other pairing, I hope this works for you as well as it did for me.

And, as always, thanks to the dev team!


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes