Post Reply

[KERNEL] vz-oc-linaro kernel v4: CM10.1 overclocking kernel - Linaro build

OP vanja_z

24th February 2013, 10:40 PM   |  #51  
Member
Bellevue
Thanks Meter: 9
 
55 posts
Join Date:Joined: May 2012
Quote:
Originally Posted by vanja_z

There has been a lot of active development on the kernel for our device with new commits almost every day. For this reason, the kernels I put up have been becoming outdated pretty quickly. For example, the cm10.1-oc(-linaro).2 builds are only EXACTLY compatible with the 20130219-NIGHTLY. You may find the kernels also work with other builds however it is not guaranteed.

I will be putting up new builds roughly once per fortnight and I will attempt to keep the compatibility section up to date.

Havent had a chance to say thanks for your hardwork putting this kernel. This kernel is awesome, made my HOXL fluid and snappier with the 1.7 OC. Keep the good work. once again thank you.
24th February 2013, 11:38 PM   |  #52  
macropterous's Avatar
Senior Member
nyc
Thanks Meter: 46
 
178 posts
Join Date:Joined: May 2012
Quote:
Originally Posted by bball606

For anyone who flashed this kernel, can you boot into the 2/24 CM nightly using the boot.img from that zip? Me and a few others are experiencing a boot loop on the latest nightly over in the CM10.1 thread after flashing this kernel.

I'm running 2.22 cm10.1 with linaro_vz2, no problems.

dbd
24th February 2013, 11:49 PM   |  #53  
Member
Thanks Meter: 0
 
31 posts
Join Date:Joined: Feb 2011
Quote:
Originally Posted by macropterous

I'm running 2.22 cm10.1 with linaro_vz2, no problems.

dbd

Sorry, my question was very unspecific. I mean the stock CM kernel, not this one.
It seems that after flashing this kernel and then flashing the 2/24 nightly (and running the stock boot.img from CM zip) there is a bootloop. Once this kernel, or an older CM boot.img is flashed, the device can boot.
25th February 2013, 09:15 AM   |  #54  
Senior Member
Thanks Meter: 31
 
234 posts
Join Date:Joined: Sep 2012
Re: [KERNEL] vz-oc kernel: CM10.1 overclocking, normal & Linaro builds
Quote:
Originally Posted by thcue

Have a feeling we will have s2w soon

Sent from my One X using xda premium

I'm looking forward

Send from my One XL CM10.1
26th February 2013, 12:22 AM   |  #55  
blacklistedcard's Avatar
Senior Member
Thanks Meter: 53
 
519 posts
Join Date:Joined: Dec 2010
Re: [KERNEL] vz-oc kernel: CM10.1 overclocking, normal & Linaro builds
Quote:
Originally Posted by bball606

Sorry, my question was very unspecific. I mean the stock CM kernel, not this one.
It seems that after flashing this kernel and then flashing the 2/24 nightly (and running the stock boot.img from CM zip) there is a bootloop. Once this kernel, or an older CM boot.img is flashed, the device can boot.

I'm running 2/24 nightly and with this kernel its booting fine. I did notice that there were other people with the same problem.

Sent from my One X using xda app-developers app
26th February 2013, 12:25 AM   |  #56  
Member
Thanks Meter: 0
 
31 posts
Join Date:Joined: Feb 2011
h8 said bootlooping was caused by a recent commit that should be fixed in the next nightly. As far as I know this kernel wasn't the issue.
26th February 2013, 12:35 AM   |  #57  
blacklistedcard's Avatar
Senior Member
Thanks Meter: 53
 
519 posts
Join Date:Joined: Dec 2010
Re: [KERNEL] vz-oc kernel: CM10.1 overclocking, normal & Linaro builds
Quote:
Originally Posted by bball606

h8 said bootlooping was caused by a recent commit that should be fixed in the next nightly. As far as I know this kernel wasn't the issue.

I was lucky that I don't have the reboot problem that other people were having with the last nightly.

Sent from my One X using xda app-developers app
26th February 2013, 07:23 AM   |  #58  
Senior Member
Thanks Meter: 82
 
439 posts
Join Date:Joined: May 2010
More
Running 2.22 with the linaro 2 (last file in the list). Everything except wifi seems to work fine.

Edit: useful information time. Instead of just saying "it's not working", I'll provide some description.
I toggle the wifi setting to on, and it says "turning wifi on..." but it never comes on.
Logcat say:

Code:
D/WifiService(  464): setWifiEnabled: true pid=1181, uid=1000
D/BluetoothAdapter(  675): 1090326768: getState() :  mService = null. Returning STATE_OFF
D/BluetoothAdapter( 1181): 1089374768: getState() :  mService = null. Returning STATE_OFF
E/WifiStateMachine(  464): Failed to load driver!
D/BluetoothAdapter(  675): 1090326768: getState() :  mService = null. Returning STATE_OFF
E/WifiStateMachine(  464): DriverFailedState
D/BluetoothAdapter( 1181): 1089374768: getState() :  mService = null. Returning STATE_OFF
Last edited by nickeedoo; 26th February 2013 at 07:26 AM.
26th February 2013, 01:11 PM   |  #59  
macropterous's Avatar
Senior Member
nyc
Thanks Meter: 46
 
178 posts
Join Date:Joined: May 2012
Quote:
Originally Posted by nickeedoo

Running 2.22 with the linaro 2 (last file in the list). Everything except wifi seems to work fine.

Edit: useful information time. Instead of just saying "it's not working", I'll provide some description.
I toggle the wifi setting to on, and it says "turning wifi on..." but it never comes on.
Logcat say:

Code:
D/WifiService(  464): setWifiEnabled: true pid=1181, uid=1000
D/BluetoothAdapter(  675): 1090326768: getState() :  mService = null. Returning STATE_OFF
D/BluetoothAdapter( 1181): 1089374768: getState() :  mService = null. Returning STATE_OFF
E/WifiStateMachine(  464): Failed to load driver!
D/BluetoothAdapter(  675): 1090326768: getState() :  mService = null. Returning STATE_OFF
E/WifiStateMachine(  464): DriverFailedState
D/BluetoothAdapter( 1181): 1089374768: getState() :  mService = null. Returning STATE_OFF

Good info, thanx.

I am running the 2.22 nightly with the linaro2 kernel as well, and Wifi is able to connect. I have noticed dropped WiFi signal and inconsistent WiFi connectivity, which has been reported on the CM10.1 issue tracker.

dbd
26th February 2013, 01:30 PM   |  #60  
OP Senior Member
Thanks Meter: 133
 
125 posts
Join Date:Joined: Oct 2012
I am really glad that people are enjoying this kernel but I would like to urge you guys to NOT report any issues in the CM10.1 thread or anywhere other than in this thread unless you are using the stock kernel for that ROM.

Also, just to reiterate, cm10.1_vz-oc(linaro).2.zip kernels are ONLY properly compatible with cm-10.1-20130219-NIGHTLY-evita.zip

ps. I will look at Rohans helpful suggestion soon but probably not for the next build.
Last edited by vanja_z; 26th February 2013 at 02:58 PM.

The Following 4 Users Say Thank You to vanja_z For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in One X Original Android Development by ThreadRank