Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Mini Pro][SK17] Hardware Keyboard FIX

OP DooMLoRD

10th April 2013, 03:11 PM   |  #101  
Senior Member
Flag Dubai
Thanks Meter: 6
 
112 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by Un.Knowen

Hmmmm
You should Flash Any Rom Firmware or Custom
cause without this files HW keyboard won't even work I guess
Give Stock ICS 4.1.B.0.587 a try, It's Generic and MUST Have the specific files

somehow it is working but i dont want to flash a stock rom because i like Cm 9.1 :L

---------- Post added at 05:11 PM ---------- Previous post was at 04:36 PM ----------

Quote:
Originally Posted by Un.Knowen

Hmmmm
You should Flash Any Rom Firmware or Custom
cause without this files HW keyboard won't even work I guess
Give Stock ICS 4.1.B.0.587 a try, It's Generic and MUST Have the specific files

Here is the thing
When i Install this

http://forum.xda-developers.com/show....php?t=2094572

The link which says keyboard and fix, i get such a folder in my system/usr called keyboard-config
but the layouts are for the x10
17th April 2013, 06:16 PM   |  #102  
Un.Knowen's Avatar
Senior Member
Flag Damascus
Thanks Meter: 98
 
195 posts
Join Date:Joined: Sep 2011
More
Quote:
Originally Posted by Naweed Reza

somehow it is working but i dont want to flash a stock rom because i like Cm 9.1 :L

---------- Post added at 05:11 PM ---------- Previous post was at 04:36 PM ----------



Here is the thing
When i Install this

http://forum.xda-developers.com/show....php?t=2094572

The link which says keyboard and fix, i get such a folder in my system/usr called keyboard-config
but the layouts are for the x10

Ohhh
That's the problem
you're not on stock rom
anyway the solution is super easy
just change the settings for hardkeyboard
Done.
FXP CM9.1 included that option a long time
17th April 2013, 06:22 PM   |  #103  
Senior Member
Flag Dubai
Thanks Meter: 6
 
112 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by Un.Knowen

Ohhh
That's the problem
you're not on stock rom
anyway the solution is super easy
just change the settings for hardkeyboard
Done.
FXP CM9.1 included that option a long time

yeahhhhh
Still doesnt work
I've changed keyboard language in the CM keyboard settings
Doesnt help
I either get arabic only without having the same symbol layout as my HW keyboard or I get english with the same problem
Not same symbol layout as what is printed on my keyboard
19th April 2013, 10:59 PM   |  #104  
Un.Knowen's Avatar
Senior Member
Flag Damascus
Thanks Meter: 98
 
195 posts
Join Date:Joined: Sep 2011
More
Quote:
Originally Posted by Naweed Reza

yeahhhhh
Still doesnt work
I've changed keyboard language in the CM keyboard settings
Doesnt help
I either get arabic only without having the same symbol layout as my HW keyboard or I get english with the same problem
Not same symbol layout as what is printed on my keyboard

IDK mate
I've never looked enough in cm rom files
sorry i couldn't help
good luck
13th June 2013, 02:17 PM   |  #105  
deezaye's Avatar
Junior Member
Flag Hameenlinna
Thanks Meter: 0
 
18 posts
Join Date:Joined: Dec 2012
More
Keyboard layout in ConnectBot
I have SK17, with locked bootloader, stock kernel and Zelly Cream ROM, and my hardware keyboard layout is SE-FI. After the ROM installation, SE-FI layout disappeared, and it became to english layout. I edited keyprint.xml and got SE-FI -layout working again, but in Irssi ConnectBot, ConnectBot and VX ConnectBot programs hardware keyboard layout is still english! in settings and connections it is SE-FI, but when program connects to ssh shell, layout is english. Any solution how to get correct layout to ConnectBot also? I use IRC a lot, and incorrect keyboard layout is annoying....
7th July 2013, 04:20 PM   |  #106  
Another way
I had the same problem before based on stock rom....
I've tried your post but it doesn't work for me; so I've tried to fix that by myself then I found another way to fix that maybe it will work for other people:




SO HERE WHAT I DID:

Quote:

-Make backup first.
-Go to: system\usr\keyboard-config\layouts on root explorer.
-Copy and past "your_langue.xml" in the same place. (ex: for me: "arabic.xml")
-Delete "qwerty-en.xml".
-Rename "your_langue copy.xml" to "qwerty-en.xml".
-Reboot.
-Tell me if it works with you!!!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes