5,599,033 Members 31,831 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Issues installing ANY custom recovery on

Tip us?
 
h_smith
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 14
Join Date: Oct 2013
Question [Q] Issues installing ANY custom recovery on

NOTE: I'M STILL ON 4.2.2

So I've already rooted my device using motochopper and had no issues, but now I'm trying to install a custom recovery to no luck. I prefer TWRP but every time I try to install via Odin it fails with this message:

<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> recovery.img
<ID:0/004> NAND Write Start!!
<ID:0/004>
<ID:0/004> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

I've installed the latest drivers and ran ODIN as admin. I tried an older version of TWRP and even ODIN but end with the same result.

When I try via GooManager, it finds the correct version and takes me to the download page, but after the countdown it never downloads and eventually times out.

So then I decided to go CWM via RomManager. It found the correct CWM recovery image and said the install was successful, but when I try to boot into recovery I get the standard Android recover screen with "reboot system" etc.. with the little Android robot with a red triangle coming out of him.

Every method I've tried is failing and I can't figure out why
 
scott14719
Old
#2  
scott14719's Avatar
Senior Member
Thanks Meter 786
Posts: 2,000
Join Date: Dec 2011
Quote:
Originally Posted by h_smith View Post
NOTE: I'M STILL ON 4.2.2

So I've already rooted my device using motochopper and had no issues, but now I'm trying to install a custom recovery to no luck. I prefer TWRP but every time I try to install via Odin it fails with this message:

<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> recovery.img
<ID:0/004> NAND Write Start!!
<ID:0/004>
<ID:0/004> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

I've installed the latest drivers and ran ODIN as admin. I tried an older version of TWRP and even ODIN but end with the same result.

When I try via GooManager, it finds the correct version and takes me to the download page, but after the countdown it never downloads and eventually times out.

So then I decided to go CWM via RomManager. It found the correct CWM recovery image and said the install was successful, but when I try to boot into recovery I get the standard Android recover screen with "reboot system" etc.. with the little Android robot with a red triangle coming out of him.

Every method I've tried is failing and I can't figure out why
I'm assuming you are AT&T SGH-i337?

If so, are you using the LOKI'd versions?

If you don't know what that means, I suggest you do a search and some reading.

If you know what it means and have used the correct version, may be someone else can help.
.
.
SGH-I337 (AT&T) 32GB
P-ROM (1st Gen.), De-Odexed, AMDL
Rooted
Auto-LOKI OUDHS CWM


Make sure you read and understand the "PINNED" threads in the "General" and "Q & A" sections of the AT&T S4 forum BEFORE you ask for help. Use the forum's "search" function to find posts with additional information. You should not expect others to help you if you haven't tried to help yourself first. Also, read, understand, and follow the "XDA" rules.
 
jd1639
Old
#3  
jd1639's Avatar
Recognized Contributor
Thanks Meter 2256
Posts: 7,397
Join Date: Sep 2012
Location: Minnetonka, MN
Sounds like nothing is able to write to the recovery partition. You might consider flashing the stock firmware with odin and starting over.
 
h_smith
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 14
Join Date: Oct 2013
Quote:
Originally Posted by jd1639 View Post
Sounds like nothing is able to write to the recovery partition. You might consider flashing the stock firmware with odin and starting over.
so is there something wrong I may have done to cause this? I wish GooManager would just download and install as I've had luck using it in the past but it won't for some reason.
 
h_smith
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 14
Join Date: Oct 2013
Quote:
Originally Posted by scott14719 View Post
I'm assuming you are AT&T SGH-i337?

If so, are you using the LOKI'd versions?

If you don't know what that means, I suggest you do a search and some reading.

If you know what it means and have used the correct version, may be someone else can help.
Yes I'm on the AT&T version. I got the LOKI files from here
 
TheEgonSpengler
Old
#6  
Member
Thanks Meter 12
Posts: 72
Join Date: Nov 2013
What baseband?

Sent from my i337 MF3 using tapatalk.
Using Tapatalk
 
scott14719
Old
#7  
scott14719's Avatar
Senior Member
Thanks Meter 786
Posts: 2,000
Join Date: Dec 2011
I'm not sure how much damage you have already done to your recovery partition so you made need to ODIN AMDL stock onto your phone before anything will work. However, here is the TWRP page for this device that also gives instructions on how to install via ADB or Terminal Emulator. Make sure you read EVERYTHING!

http://www.teamw.in/project/twrp2/174

Once you get TWRP working, you can flash a compatible version of CWM if you want to.

For future reference NEVER do anything to your phone that you don't read about here on XDA or at least see that people on XDA have tried it and verified it to work. Most sites (I'm not positive about the one you linked) just copy the information from XDA and claim it is there own. Usually, screwing it up some how. So never trust anything outside of XDA or that isn't directly linked to XDA. An example of something to trust is with the TWRP site. You can trust it as long as you make sure you have the correct information and version for your phone. That is your responsibility.

Also, make sure you search and read before asking questions or advice. Most information is already posted and you need to read about everything you are trying to do to your phone. If you follow these guidelines, you should do OK. If you try to cut corners or not search and read, you will end up in a mess. Good luck.
.
.
SGH-I337 (AT&T) 32GB
P-ROM (1st Gen.), De-Odexed, AMDL
Rooted
Auto-LOKI OUDHS CWM


Make sure you read and understand the "PINNED" threads in the "General" and "Q & A" sections of the AT&T S4 forum BEFORE you ask for help. Use the forum's "search" function to find posts with additional information. You should not expect others to help you if you haven't tried to help yourself first. Also, read, understand, and follow the "XDA" rules.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...