5,601,062 Members 46,863 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Factory image restore with NRT, stuck at "writing system"

Tip us?
 
shin_komuta
Old
#1  
shin_komuta's Avatar
Junior Member - OP
Thanks Meter 1
Posts: 4
Join Date: Sep 2010
Default [Q] Factory image restore with NRT, stuck at "writing system"

Hi everyone,

Yesterday, I tried the 4.4 OTA on my wifi Nexus 10 (unlocked but not rooted, previously 4.3), but got an "Error!" screen, and now the device seems soft-bricked (can't boot into system, get a "No command" screen, but I can get the bootloader screen with Power + both volume keys).

After some investigation, I tried restoring a factory image using Nexus Root Toolkit v1.7.8, after recharging the device a full night. I used the "Flash Stock + Unroot" with "Soft-bricked / Bootloop" option. At first everything looked fine, but I'm now stuck at "writing system" step, for 30 min now:



The strange thing beeing, the device shows "Fastboot status - okay":


Might it be a sync status problem between NRT and the device? Is it safe to stop the operation and try to reboot my Nexus?

Thanks for your help.
 
rgomesf
Old
#2  
Member
Thanks Meter 2
Posts: 69
Join Date: Feb 2008
Hi. I have the same problem.

How did you manage to solve this?

Regards
Nexus 10: LiquidSmooth
Galaxy Nexus: LiquidSmooth
Transformer: ParanoidAndroid
LG 2X: 4.0.4
Revue: 3.2
 
shin_komuta
Old
#3  
shin_komuta's Avatar
Junior Member - OP
Thanks Meter 1
Posts: 4
Join Date: Sep 2010
Hi,

Yes I did.

I was still stuck in the "writing system" test, and rebooted the device. As I feared, the system didn't boot, so retried the stock kitkat flash through NRT. The second pass got me to the same result, stuck in "writing system" with the device saying "fastboot okay".

I decided to reboot to recovery, and wiped both system and cache partition. When I reboot, I was able to see the kitkat startup screen, and then everything went fine.

Eventually, I'm not able to tell what went wrong or good with the flashing, but here are my observations and facts :
- once launched, the system initialized correctly, and I didn't encounter any problem since then
- even if the system partition appears to be flashed correctly, I was still amazed that everything works, since the user partition hasn't been written
- only the stock system has been installed. No root nor custom recovery.

As for the root cause of the initial OTA problem, I think it was caused by lack of battery power.
The Following User Says Thank You to shin_komuta For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes