5,598,463 Members 46,523 Now Online
XDA Developers Android and Mobile Development Forum

[Q] [Help] No cell service after wipe

Tip us?
 
Avuton Olrich
Old
(Last edited by Avuton Olrich; 1st December 2013 at 05:01 AM.) Reason: Clarification
#1  
Junior Member - OP
Thanks Meter 6
Posts: 6
Join Date: Apr 2012
Question [Q] [Help] No cell service after wipe

Hello,

This is going to be kinda long, I want to give all details I can remember in case it helps.

I decided this morning that I was going to try out the unofficial CM11 rom for Galaxy Nexus GSM. So, first thing I do is a backup from Clockwork Recovery (latest touch recovery flashed).

After that, I flash the rom, and the gapps. I reboot to see if it works, and after 5 minutes of use everything looks pretty sucessful.

So, adb pull my backup and offload it to my computer in the case that something goes really wrong, because I'd like to get a clean start. So, I wipe the device as completely as I can in Clockworkmod Recovery. I then adb push the cm11 rom and the gapps roms referenced above. I use Clockworkmod Recovery to flash those onto the device, reboot and start playing around then realize that I have no cell service. Try manually registering on my T-mobile to no avail.

I think this is a baseband problem, so I fastboot flash radio (stock nexus radio rom from 4.3), reboot into the system and still no service.

Then I begin thinking my phone radio has completely failed, so I take a simcard from my girlfriend's phone pop it into mine, reboot and still no service. Reinstall my original sim card.

Then I am REALLY thinking my radio has failed, so I figure I'll just flash the full 4.3 stock suite in case I'm missing something small because I don't understand how something works. Still no service.

So, as a last resort, I push the Clockworkmod Recovery backup back into the /sdcard/0 directory, restore in Clockworkmod Recovery, reboot and it works(!).

Now I start wondering what I'm failing to understand about this problem, so I go ahead and do a factory reset in Clockworkmod Recovery and back to no service(!).

I really thought I understood how it worked, but I must be missing something here, or maybe Clockworkmod Recovery is wiping something it shouldn't be? The final thing I can add is each time I fail to get service in the installation, the service bars light up for 1/2 second to 2 seconds during boot. Maybe someone could help me spitball what's happening here?

Thank you very much in advance.
 
aalok.kashyap
Old
#2  
aalok.kashyap's Avatar
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Sep 2011
I think all yu must do is download the latest stock firmware ment for for your device.. from internet.. and install that properly on yur device.. this will do every thing right.. see I too am not at all good with using programme stuff and so.. therefore I keep the copy of firmware with me always.. that helps when I almost destroy my phone
tc and good luck..

---------- Post added at 04:01 AM ---------- Previous post was at 03:56 AM ----------

and it might be possible thet the rom which yu are trying is not ment for your device version.. chack that too correctly..
 
Avuton Olrich
Old
#3  
Junior Member - OP
Thanks Meter 6
Posts: 6
Join Date: Apr 2012
Thumbs up Problem found (not yet solved, but that's another question)

OK, I found the problem. My non volatile memory got corrupted. I pulled an image from the EFS nv memory partition devfs file, mounted it as loop on my localhost and got nothing but a lost+found directory. It's not a terrible thing, but from now on when I wipe this phone, I will need to adb push my /data/radio backup to the EFS nv memory partition. That is, at least until I find out exactly what I need to do to reconstruct the memory partition. Shouldn't be that hard, but I really need a good description of what is in all the EFS memory partition files for the Galaxy Nexus. I'll dig around the forums a bit, maybe ask someone for the directory structure, maybe I'll be able to, at least, partially restructure that memory partition with a good old dd'ing. Maybe I'll root my girlfriend's Galaxy Nexus so I can get the structure proper.

Hope this helps someone else!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes