Default [Q] ROM issues

I tried following some guide online to get my S3 rooted and running stock Jelly Bean and all was going so well...Casual Root worked like a charm, cyanogen all set. But when I went to install the ROM and Gapps in recovery it kept getting hung up. I assumed this was due to encryption on the device from my work email, so I went back to factory andremoved the account and decrypted the device.

Then it was back to recovery to flash the ROM and Gapps. All seemed to go well,the ROM installed fine, Gapps installed fine, but reboot got stuck at the cyanagenmod loop. I had mad a backup of the original ROM, but I must have saved it to the internal SD card by accident before i factory wiped. I thought my best bet would be to load the Gapps and ROM onto my external SD and flash from there, but I cant get it to mount.

The one good thing that I can do is get to the Odin boot screen. Anyone think there's a chance I can get Odin to flash something that will boot? And does anyone have suggestions of what to flash?