Default [Q] Error updating 4.4 OTA; "This package is for "m7" devices"

Hey xda,

I got a problem, which I don't really understand and I hope you can help me with:

I got a HTC ONE and changed it quite a while ago to stock Jelly Bean (probably following this instructions redmondpie[dot]com/install-google-edition-stock-android-on-htc-one-how-to-tutorial).
Everything worked fine and yesterday I got the ota for 4.4. As I tried to install, it aborted with an error "Status 7". Wondering if it was an outdated CWRM, I updated that today, manually downloaded the ota (exact filename see below), went into recovery an tried to install from sd and got the same error, but this time with more info:

This package is for "m7" devices; this is a "m7ul".
E: Error in /data/media/o/Download/545beb486164aacd05129a1f1c221721ab0d1e97.OTA_M7_UL _K44_STOCK_UI_MR_Google_WWE_3.58.1700.5-3.07.1700.1_release_341696.zip
(Status 7)
Installation aborted.

Unfortunately I can't remember if I messed with MID, CID, but I don't think so, because I'm S-ON.

Here's what my Booloader says:
***TAMPERED***
***UNLOCKED***
M7_UL PVT SHIP S-ON RH
HBOOT-1.54.0000
RADIO-4A.17.3250.14
OpenDSP-v31.120.271.0617
OS-2.24.401.1

The App CID GEtter gives me this infos, maybe they help you:
ro.aa.cidlist GOOGL001, BD_US001
ro.aa.maincid: GOOGL001
ro.aa.modelid: PN0713000, PN0712000, PN0714000, PN0710000
ro.aa.project: M7_UL_JB43_STOCK_UI_S
ro.boot.carrier: HTC-GER
ro.boot.cid: HTC_102
ro.boot.hardware: m7
ro.boot.mid: PN0710000

From "about phone":
Kernel version
3.4.10-ge22f38b
root@abm009#1 Thu Aug 1 19:08:28 CST 2013

Build number
JWR66Y.H1


Do you guys got any hint? I'm quite a noob I guess, just managed to install custom roms and recoverys, now I'm out of ideas... any help much appreciated.