5,597,354 Members 32,385 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Rogers Galaxy S3 4.3 issues

Tip us?
 
nighthawk29
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Feb 2009
Location: Toronto
Default [Q] Rogers Galaxy S3 4.3 issues

I am curious if my hardware is the issue or if it's the 4.3 update and Samsung screwed up yet again.

I have several issues I have noticed on stock, unrooted S3 (I747M) only since 4.3 was released.

1) random (but rare) it will popup an error saying the carrier cannot set the date and time (or something to that effect) and disables the "Automatic Date & Time" option in settings;

2) Occassionally I get an error popup saying "Unfortuntely, the process com.google.process.location has stopped.";

(BOTH those 2 issues showed up from clean install with no other apps installed)

3) my phone reboots once when I reboot or turn it on but this ONLY seems to happen when an SD card is inserted. I use a Sandisk 64GB class 10 as my main but I also have a 32GB Sandisk in my tablet I tried and a PNY 32GB in my gf's camera and no matter what card it always does this but if I remove the card I have no issues. At first I started uninstalling apps 2 at a time to see if it was an app but then I tried removing the SD card and when it's removed I have no issues.

(error 3 has only started since 4.3 and it seems to happen within 2-3 days a clean install. I updated my phone on the 26th when the update went live and noticed it on the 28th so come the 29th I decided to do another factory reset and try again so by yesterday (Dec.1) it was doing this again. It also does this if I boot into safe mode with the SD card inserted, and if it's not inserted then safe mode is fine as well).


So, my main concern now is whether this is the firmware causing these issues and typical Samsung screwed up or if it's my phones hardware? These are just on top of the very laggy experience I get with TW, message notifications on the lockscreen are ridiculous it was better on 4.1.2 and older just showing a number of how many notifications because this widget is ugly as hell now showing in big my text message(s). i like to have the preview option on for when I am using the phone and a message comes through I read it in the notification bar sometimes, just to name a few annoyances outside of the bugs I am curious of.

I noticed I cannot revert back to 4.1.2 either and it seems no matter what rom I would try my battery life was great at first then within 2 weeks went to crap with almost no apps installed because I was trying to troubleshoot the battery life a while back. Just to note, it's not the battery because I am getting better battery life right now on stock 4.3 than I was on any rom lol.
 
reallyflyguy
Old
#2  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Nov 2012
I'm having all the same issues with mine....It's not your phone. I have a thread on here asking the best of the best how to change back or go custom
 
nighthawk29
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Feb 2009
Location: Toronto
Quote:
Originally Posted by reallyflyguy View Post
I'm having all the same issues with mine....It's not your phone. I have a thread on here asking the best of the best how to change back or go custom
Ah ok, thanks for the reply and glad to know it's not my phones hardware coincidentally dying on me at the same time 4.3 was released lol. I didn't think it was but the thought was still there you know.

I wish Samsung would get their acts together though. The delays to get the updates to North America are ridiculous and then on top of that they are buggy as hell. Never again am I buying Samsung products after owning my S3 and a Note 10.1 (2012) and seeing how bad they are for supporting older devices and getting working updates released to customers.
 
Florad77
Old
(Last edited by Florad77; 3rd December 2013 at 05:04 PM.)
#4  
Senior Member
Thanks Meter 40
Posts: 204
Join Date: Oct 2012
Well i have rogers s3 too and I dont have any of those issues. No lag no glitches nothing. But I do agree with you about lockscreen widget for messages. Its ugly as ****

I think if you root your phone and uninstall all the bloatware it'll be a lot faster. Thats what worked for me.

Sent from my SGH-I747M using Tapatalk
 
nighthawk29
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Feb 2009
Location: Toronto
Quote:
Originally Posted by Florad77 View Post
Well i have rogers s3 too and I dont have any of those issues. No lag no glitches nothing. But I do agree with you about lockscreen widget for messages. Its ugly as ****

I think if you root your phone and uninstall all the bloatware it'll be a lot faster. Thats what worked for me.

Sent from my SGH-I747M using Tapatalk
I was going to root and I did the first time but I wasn't sure if the root and cuz of Knox being a piece of crap caused those issues so I went to stock unrooted completely clean so I could troubleshoot and of course that didn't help so ya if I am going to be stuck with this crap I will at least root again and get rid of all that bloatware.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes