Default [Solved] [Q] Intl. version won't turn on after factory data reset. Rooted

I'm sorry if this has been answered before, I searched but wasn't able to find anything.

It started when my phone suddenly didn't recognize the sd card. I took the card out and put it back in a couple of times, and reebooted the phone a couple of times. After that didn't work, I figured I would factory reset the phone, and as I did, it started to reboot, but was never able to boot back up.

When I now try to boot the phone, I get to the initial Samsung-S4 Active GT-I9295 -logo, and it says BOOTING RECOVERY in the top left corner, but after ~2 seconds it shuts off.
Interesting: It only boots a couple of seconds after I let go of the power button.

The phone was rooted using this guide: (not able to post links. The guide is on android geeks, and can be found by searching for Root Galaxy S4 Active (International I9295 and AT&T I337 models))
And Xposed was installed, but no modules were activated.
Firmware was 4.2.2 MF/MU 3 - something, I think. Sorry I cannot remember. I got it OTA some two weeks ago.

Any suggestions?
Thank you!


EDIT: When playing around with it, I managed to solve it. When booting, as soon as the logo appeared, I pressed and held the volume up + home button, which caused it to not shut down (?). It then preceeded to boot for a long time while, I guess, the phone was factory reesetting itself. Now it boots just fine, factory reset =D . (SD card still not detected )