Default [Q] Alternative way to perform factory reset

My friend's daughter was playing with the unlocking screen and of course she locked the device for good. Since this tablet was bought some time ago just for her amusement, no one remembers what was the google account they used - possibly a phony one created just for the purpose of using the device. This discards google recovery as an option.

It's a cheapo tablet sold here by Walmart under ONN brand. I did some research and have found it's being made by YiFang Digital and marketed as M7000NBD

yifangdigital.com/product/M7000NBD.aspx


According to the manufacturer, it's powered by AML8726-MXS Dual Core + Mali TM-400 and it's running Android 4.2. I'm pretty sure it's not rooted, and it has only 3 buttons: PWR, VOL UP, VOL DOWN.


My friend doesn't care about the data stored on this device and I offered to help thinking that I will be able to perform a factory reset the usual way. I was wrong.

When I use the PWR + VOL UP key combination, to enter Android system recovery, first thing that shows up after the boot is an Android figure with a red triangle and an exclamation mark. If I press the PWR+VOL UP again, the system recovery menu shows up but I can not navigate through its options. At least not using the VOL UP/DOWN buttons. The only button that works is the PWR, but since "reboot system now" is the option selected by default, it's the only action I can perform from within this menu.




When the above failed, I thought about ADB as an alternative way. Unfortunately the USB debugging seems to be turned off so, as far as my limited knowledge goes, there is no way of running ADB shell in that case. For obvious reasons, there is also no way of switching it on.

Just to be sure, I've checked both in Windows and Ubuntu. Same story. I also don't think the ADB is enabled in recovery menu. When I connect the device it starts charging but Windows Device Manager doesn't notice any change. "Adb devices" returns nothing and "adb shell" returns "error: "device not found"

In Ubuntu, nothing shows up in lsusb while in system recovery menu and I get 2207:0000 ID when on Android's "too many attempts" screen. I can access the tablet as a storage unit (with no acces to root dir of course) but because the debugging is off, even after editing the adb_usb.ini and 51-android.rules I get nothing in "adb devices" .

Tried the bootloader/fastboot approach. My fingers hurt from trying different key combinations and I accomplished nothing. Even tried the VOL +/- >> connect USB >> press PWR several times procedure, I remember from the original Ainol Novo 7.




Is there any other option to factory reset this device? Or maybe there is a way to make the system recovery menu respond?

If it makes any difference, I have a Windows 7 desktop and two notebooks running Windows 8 and Ubuntu 13.10 respectively.

Thanks in advance for every suggestion.