5,597,397 Members 30,655 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Problem Unrooting Kindle Fire HD 8.9"

Tip us?
 
loonyone
Old
#1  
loonyone's Avatar
Member - OP
Thanks Meter 14
Posts: 57
Join Date: Feb 2011
Question [Q] Problem Unrooting Kindle Fire HD 8.9"

I'd really appreciate some assistance on this one...

I'm attempting to unroot my Kindle HD 8.9, but it's resisting my efforts. I originally rooted using the Bin4ry method (r25), but lost it when Amazon forced 8.3.1 on me. The second time, I used Kindle Fire First Aide and then also used it to disable OTA. I've now tried unrooting it with all of these methods, yet I can still access root directories in ES FIle Explorer:

1) Unroot option in KF First Aide. Says it's successful, but it isn't.
2) Unroot option in Bin4ry. It says it fails and tells me to go into the SuperSU.apk itself and select the unroot option.
3) Unroot option in SuperSU.apk. It removes the SU app, but it doesn't unroot the device.
4) Re-enable the OTA and take the 8.4.6 build. Every time I've gotten an OTA upgrade, it has unrooted the device. This time it didn't. Now I'm running on 8.4.6 and still rooted. I reinstalled the SU app, and tried unrooting options 1-3 again, and again none of them worked.

I have done a factory reset after each one of these. None of them have made a difference.

I've also noticed that I still don't have my Amazon ads on the lockscreen. I disabled them using Kindle Fire First Aide and they didn't come back when the rest of my system apps got cleared.

Thank you in advance for any help you can provide!
 
stunts513
Old
#2  
stunts513's Avatar
Recognized Contributor
Thanks Meter 497
Posts: 1,777
Join Date: Feb 2013
Location: New Braunfels, TX

 
DONATE TO ME
You could tell kffa to do a system restore, and them from there I think if it doesn't auto-update, you can simply delete /system/app/superuser.apk and then /system/xbin/su, and possibly busy box, I think that was put on there in the rooting process, I suggest removing the su binary last as to avoid possibly getting the other files stuck on there and having to reroot.

Sent from my Amazon Kindle Fire HD running CM10.1 Tablet UI using xda-developers app
My Wallpaper Fix for KF2, KFHD 7", and KFHD 8.9" is HERE
Please Read the instructions and use the debugger if you run into errors.
My own modified adb drivers for just about all kindles (includes old twrp and cm versions) HERE
Tablet UI Patch for latest CM10.1 build HERE!

Please send complaints to /dev/null
 
loonyone
Old
#3  
loonyone's Avatar
Member - OP
Thanks Meter 14
Posts: 57
Join Date: Feb 2011
Thanks for your help, Stunts513!

It now appears unrooted and doesn't have superuser installed anymore, but ES File Explorer can see the root directory and change things in /system even though I have the "root" setting turned off.

I think I'm going to call it good. Everything is working fine and it looks standard to a normal user.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes