Default [Q] A2DP bluetooth streaming trouble on 4.2.2

A week or so again I tried hooking up my A2DP bluetooth speaker with my S4, running a 4.2.2 ROM. This bluetooth speaker works great with iphones, my HP Touchpad running CM, and my Galaxy Nexus running 4.1.2. I tried it also with a friend's Note 2, running 4.1.2, and it works fine for him too.

The speaker is this one: http://www.amazon.com/Spracht-Portab.../dp/B0023B1364

Though I've owned my S4 for 6 months, it may have been the first time I tried pairing it. It paired fine. However, any music streaming attempts fail horribly. It spurts out a few seconds of sound, then goes silent. Intermittently a few more seconds of sound may pop through. If I hit some of the buttons on the speaker (stereo widening, bass boost), a few more seconds pop through, and then nothing.

This is a bit different than some of the other complaints with 'poor quality' streaming. In this case, it doesn't truly stream much. I reverted back to complete stock and had the same problem.

I remember hearing that with 4.2, there were widespread reports of poor a2dp quality, supposedly fixed with the next version (4.2.1? I forget).

Thinking something might be wrong with the bluetooth on my phone specifically, I obtained warranty service and obtained another brand-new/refurbished S4. Right out of the box same problem. This new phone was also on 4.2.2, stock.

I simultaneously obtained a bluetooth adapter for my car, which is also apt-x capable, and it works great. Maybe the apt-x protocol supersedes the a2dp, I don't know.

Anyone else with an older a2dp (only) bluetooth speaker/headset with similar issues, running 4.2.2?

Galaxy S4 T-Mobile
[ROM] Wicked v5.1
[Recovery] TWRP 2.5.0.2
------------
Galaxy Nexus GSM
[ROM] XenonHD vXVIII
[Build] JZO54K 4.1.2
[Kernel] Leankernel 4.7exp2-180/interactive/deadline
[Recovery] TWRP 2.3.3.0
[Radio] I9250XXLF1
[Bootloader] PRIMELC03
------------
HP Touchpad 32gb
[ROM] Jcsullins 7/14/13 build with battery fix