Post [Q] I softbricked my inspire, anyone can help me?

Okay, let me tell you how I soft bricked (Atl east I think its a soft bricked)

It all starts out with me unlocking my bootloader with htcdev, flashing a recovery on it, then putting superuser.

I wanted to install CM 10.1. I don't have s-off, so I read up on how to do it with the procedure of fastboot flash boot boot.img. I put the zip file on ym sdcard and I went into 4ext, wiped cache and dalvik factory reset , and formated system. I rebooted into bootloader and flashed the boot.img. Rebooting it, it got stuck on black screen. With a little research, i found out my hboot probably did not support the jellybean (cm) I was flashing onto it. So I download a gingerbread rom and used the boot.img of that to try and fixed it, it went into a bootloop. Later on after trying this again, it softbricked (Stuck on htc screen). I tried to install another rom onto it , GizRoot. Its a gingerbread rom. It did not help whatsoever.... Anyone can help me with this?