5,594,653 Members 33,211 Now Online
XDA Developers Android and Mobile Development Forum

GPS won't lock even after many attempts to fix

Tip us?
 
azeem40
Old
#1  
Senior Member - OP
Thanks Meter 193
Posts: 651
Join Date: Jun 2013
Default GPS won't lock even after many attempts to fix

Hello XDA Developers,
I come to you all with a problem. I am having trouble with my GPS; it won't lock. I have tried these things:
Using GPS Status and other GPS fixers
Doing a factory reset using Mr. Cook's ROM Wipe Script
Clearing data and cache of my GPS apps (Waze and Google Maps)

Idk what else to do. Every time I use the GPS apps to pinpoint my location, after a navigation session, it goes back to getting stuck on "waiting for GPS".

Any help is appreciated.
 
creepyncrawly
Old
#2  
Recognized Contributor
Thanks Meter 2659
Posts: 2,346
Join Date: Sep 2010

 
DONATE TO ME
What firmware are you running? Have you had the same problem with other firmware?
The Following User Says Thank You to creepyncrawly For This Useful Post: [ Click to Expand ]
 
azeem40
Old
#3  
Senior Member - OP
Thanks Meter 193
Posts: 651
Join Date: Jun 2013
Quote:
Originally Posted by creepyncrawly View Post
What firmware are you running? Have you had the same problem with other firmware?
I am currently on an unofficial nightly of CM11 ported by RenderBroken. When I was experiencing those problems, I was on Omni ROM for Android 4.4. I was on ShoStock3 before the Omni ROM, and it was the same problem.
 
creepyncrawly
Old
#4  
Recognized Contributor
Thanks Meter 2659
Posts: 2,346
Join Date: Sep 2010

 
DONATE TO ME
I don't run anything AOSP based so I can't speak about how those might affect GPS, but since you have the problem across various roms, and even on SHOstock3, I wonder if the phone has a problem with the GPS hardware? Have you ever had good GPS at any point with that phone? If so what were you running at the time.

I've had some GPS issues in the past but am not having any issues currently. I've been on SHOstock3 for a long time. My issues were on an earlier version of SHOstock, I don't remember which one exactly. When my GPS would fail to lock, just as you described, a reboot would fix the issue and result in a fast lock, but then the next time I would try to use GPS, I would have to reboot again. It was very annoying. Someone said that to format cache, wipe dalvik cache and fix permissions would fix the problem, so I tried that, and yes I would then get a lock in 5 - 10 seconds and it would stay good for a few weeks until I would have to do it again. I never experimented to see which of those three things helped, or if you had to do all three. That was back around June or July of this year.

As I recall, the next base change on SHOstock completely eliminated the issue.
The Following User Says Thank You to creepyncrawly For This Useful Post: [ Click to Expand ]
 
azeem40
Old
#5  
Senior Member - OP
Thanks Meter 193
Posts: 651
Join Date: Jun 2013
Quote:
Originally Posted by creepyncrawly View Post
I don't run anything AOSP based so I can't speak about how those might affect GPS, but since you have the problem across various roms, and even on SHOstock3, I wonder if the phone has a problem with the GPS hardware? Have you ever had good GPS at any point with that phone? If so what were you running at the time.

I've had some GPS issues in the past but am not having any issues currently. I've been on SHOstock3 for a long time. My issues were on an earlier version of SHOstock, I don't remember which one exactly. When my GPS would fail to lock, just as you described, a reboot would fix the issue and result in a fast lock, but then the next time I would try to use GPS, I would have to reboot again. It was very annoying. Someone said that to format cache, wipe dalvik cache and fix permissions would fix the problem, so I tried that, and yes I would then get a lock in 5 - 10 seconds and it would stay good for a few weeks until I would have to do it again. I never experimented to see which of those three things helped, or if you had to do all three. That was back around June or July of this year.

As I recall, the next base change on SHOstock completely eliminated the issue.
I have had a lock before. When I used GPS Status, it would get a lock for a short while, but when I ran the navigation, it would get stuck at waiting for location again.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes