Default [Q] Brick / Boot loop problem

I honestly need help.
I'm not sure what to categorize my issue under.

I am stuck in a screen with the green android and the spinning thing in the middle, with a progress bar, but the bar just has a moving animation, looks like it is moving to the left, not getting longer or filling up like usual progress bars.
I am unable to get to the boot loader or recovery.

The issue started after I flashed Cyanogen Mod 10.2 Stable.
it booted fine then, but when I went to use it, it would have a never ending cycle of app not responding at the part where it asks to sign in to cyanogenmod account. I got to settings without signing in by quickly sliding the status bar and clicked on factory reset.

From there it proceded to reboot and now I am stuck in the screen described.

I have tried all the button combinations, reset with pin, nothing will get to bootloader or recovery.
ADB does not find the device, also no devices found when try fastboot devices line.

I have also tried putting the firmware zip on a microsd, but nothing new happens either.
any suggestions appreciated.


** edited ** Issue is resolved. Turns out I just needed to wait longer (about 2 hrs) ... I did turn it off using combo of power and Vol -, left it off overnight, turned it on in the morning and left it alone. I finished whatever it was trying to do, and now CyanogenMod 10.2 stable is working great.