5,600,984 Members 43,884 Now Online
XDA Developers Android and Mobile Development Forum

[Q] [C1905/15.1.C.17] Help - Annoying calling problems

Tip us?
 
atomn
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
Default [Q] [C1905/15.1.C.17] Help - Annoying calling problems

Hi there,
I bought this device recently, and soon noticed it is quit though to have a decent conversation with it.
Basically after one minute the signal seems lost, I cannot hear properly the other person, then it comes back, then the call hangs up..and so on.
Anyone having any similar experiences with this phone? Is there any way to fix it? Is there anything I could try to do?
Thanks.
 
giridhargp
Old
#2  
Senior Member
Thanks Meter 56
Posts: 260
Join Date: Nov 2013
Location: bangalore
Quote:
Originally Posted by atomn View Post
Hi there,
I bought this device recently, and soon noticed it is quit though to have a decent conversation with it.
Basically after one minute the signal seems lost, I cannot hear properly the other person, then it comes back, then the call hangs up..and so on.
Anyone having any similar experiences with this phone? Is there any way to fix it? Is there anything I could try to do?
Thanks.
Try changing network mode to gsm only,

Setting-more-mobile network-network mode

Sent from my C1904 using XDA Premium 4 mobile app

---------- Post added at 07:00 AM ---------- Previous post was at 07:00 AM ----------

And update ur firmware

Sent from my C1904 using XDA Premium 4 mobile app
 
atomn
Old
(Last edited by atomn; 8th December 2013 at 11:05 AM.) Reason: grammar
#3  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
Quote:
Originally Posted by giridhargp View Post
Try changing network mode to gsm only,

Setting-more-mobile network-network mode

Sent from my C1904 using XDA Premium 4 mobile app

---------- Post added at 07:00 AM ---------- Previous post was at 07:00 AM ----------

And update ur firmware

Sent from my C1904 using XDA Premium 4 mobile app
Hello,
thanks for replying.
This does mean I would lose the 3G internet speed, doesn't it?
If so, I don't think that it is an option.
 
giridhargp
Old
#4  
Senior Member
Thanks Meter 56
Posts: 260
Join Date: Nov 2013
Location: bangalore
Quote:
Originally Posted by atomn View Post
Hello,
thanks for replying.
This does mean I would lose the 3G internet speed, doesn't it?
If so, I don't think that is an option.
Yup,but what happens is whenever 3g n/w is low,its keeps on searching for network,wont switch to 2g that easily,,so I thought that may be ur prob I think

Sent from my C1904 using XDA Premium 4 mobile app
 
atomn
Old
(Last edited by atomn; 8th December 2013 at 01:10 PM.) Reason: typo
#5  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
It looks like I can have a decent call with both the settings "GSM only" and "WCDMA only" (with data disabled).
I finished my data allowance for the month and my operator set me a limit of 32k. Could that cause the problem? So there isn't a real device issue?
I have always thought that data and voice had different separated bandwith ranges, speaking in terms of frequency...
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes