Default [Q] Odd graphical glitches/wont boot after flashing CM10.2

Hey guys, I've been working on this all day, finally got cm10.2 and gapps installed. I was in stuck booting into TWRP, but then sideloaded cm10.2 and gapps, I thought I was finally done... then when it loads up it has the orange kindle Fire logo, then has a brief "noise" sort of affect on part of the screen, then after that it just has a vertical sort of flashing line of blue down the center. Anyone have any idea whats going on? I've been doing some research and I cant find anything about that... if there is already an established issue and thread, please point me there, but otherwise...anyone know whats going on? I'd really rather not have to get the factory cable, mainly just because of the shipping time, but can if thats needed.

EDIT 1: It wont actually do anything when its stuck after the kindle fire logo, its just black w/ the line. Lately it hasnt even been displaying the blue line (more like whatever color it feels like though). I cant use either ADB or fastboot commands using KF First Aid either.

EDIT 2: Just realized I forgot to say some important info, sorry. I have a KFHD7". I followed some XDA tutorials and only really had trouble right after I sideloaded my CM10.2 rom, and thats the problem I'm having right now.

EDIT 3: I did some more testing. I think I sort of got into fastboot mode, but no "Fastboot" logo like I'm used to. I have the kindle off and unplugged,then tried fastboot -i 0x1949 getvar product, and got "Bowser-04". From what I can see, there is really nothing on Google about this so I'm assuming thats not supposed to be there. I tried to take this one step further and flash the right TWRP recovery 2.6, but it just hangs on <waiting for device>. So it seems like it is ALMOST there...but not.


FINAL EDIT: Fixed. For anyone else having this problem, I used the little bit of actual fastboot mode I had to give the fastboot command to load into fastboot (reboot-bootloader) and then it would load me into actual fastboot w/ the "Fastboot" logo on the screen, but that would only last a couple of seconds. I was then able to use the http://forum.xda-developers.com/showthread.php?t=1951254 and restored img/boot/etc, then installed stock recovery and cleared data/cache. Now it actually loaded up and I have a normal kindle again! I'm going to reinstall the RIGHT stuff and not have this happen again now.