5,596,179 Members 34,013 Now Online
XDA Developers Android and Mobile Development Forum

MicroSD card ejected when listening to music...

Tip us?
 
alesa1988
Old
#1  
alesa1988's Avatar
Member - OP
Thanks Meter 5
Posts: 30
Join Date: Dec 2013
Location: Madrid
Unhappy MicroSD card ejected when listening to music...

Hello everyone.. I've been a lurker of the forums for the last 3 or so years, and... Well finally decided to make an account as I really can't find any help anywhere else, plus you guys are awesome, really :P

I'd like to make it clear first that my problem is unrelated to similar threads as I will explain...

My S4 spits out my SanDisk Ultra 32GB (Most threads point to 64GB) MicroSD card whenever I play music, irrelevant of player.. (Samsung default Music app, and PowerAmp Pro.) Usually when launching, it is unnecessary to play a file.. Both ejecting and re-inserting the card manually or restarting the phone does absolutely nothing...

I've had this issue since firmware release AMDE, though it was tolerable as it only occurred once a week or so... Since EMK8 however my phone is absolutely useless when it comes music as this occurs when launching any music app...

I should point out, I've tested the card further on an i8190 using benchmarking and SD testing apps as well as the 2 music players I use on my i9505 and it had no issues what so ever...



PS: Suffice to say I did a wipe with every firmware upgrade....



I'm assuming this is most likely a device issue, but I tripped Knox Warranty to 0x1 when rooting the day I got the phone (I got it when MH8 released, but used the old firmware for a few hours..)


What can I try? Has anyone with the same issue found more luck with another music app?


Thank you in advance
 
AnaMajhol
Old
#2  
AnaMajhol's Avatar
Senior Member
Thanks Meter 51
Posts: 196
Join Date: May 2012
Location: YOUR BACKYARD
Try to format the sd card.. and if you want, format it from the phone itself.. Good luck

Sent from my GT-I9505 using Tapatalk
 
alesa1988
Old
#3  
alesa1988's Avatar
Member - OP
Thanks Meter 5
Posts: 30
Join Date: Dec 2013
Location: Madrid
Quote:
Originally Posted by AnaMajhol View Post
Try to format the sd card.. and if you want, format it from the phone itself.. Good luck

Sent from my GT-I9505 using Tapatalk
I'm sorry I forgot to mention I've tried that too, both from Windows, HP Disk Tools, and from the phone itself.. Using FAT32 and exFAT, both. No difference.
 
AnaMajhol
Old
#4  
AnaMajhol's Avatar
Senior Member
Thanks Meter 51
Posts: 196
Join Date: May 2012
Location: YOUR BACKYARD
Quote:
Originally Posted by alesa1988 View Post
I'm sorry I forgot to mention I've tried that too, both from Windows, HP Disk Tools, and from the phone itself.. Using FAT32 and exFAT, both. No difference.
I don't know if this helpful or makes sense, But why don't you try to mount your sd card as the internal storage ( there's a thread in the I9505 development helps you )

Sent from my GT-I9505 using Tapatalk
The Following User Says Thank You to AnaMajhol For This Useful Post: [ Click to Expand ]
 
alesa1988
Old
#5  
alesa1988's Avatar
Member - OP
Thanks Meter 5
Posts: 30
Join Date: Dec 2013
Location: Madrid
Quote:
Originally Posted by AnaMajhol View Post
I don't know if this helpful or makes sense, But why don't you try to mount your sd card as the internal storage ( there's a thread in the I9505 development helps you )

Sent from my GT-I9505 using Tapatalk
Thank you, though I don't think I really wanna touch that.. Seeing as if the card decides to unmount in that way it may end up worse, I think....

I've been searching a bit more and found a thread on another forum, it appears that the 32GB SanDisk Ultra card is giving problems with many Samsung devices, maybe I was just lucky with my old S3 Mini... I guess it's time to go back to Lexar cards again for me...
 
alesa1988
Old
#6  
alesa1988's Avatar
Member - OP
Thanks Meter 5
Posts: 30
Join Date: Dec 2013
Location: Madrid
Well, I've made a couple of new discoveries and am glad to say that the issue has been resolved! It did take a bit more investigating to find out the cause, however.... Apparently the issue occurs when using the early 32GB and 64GB SanDisk Ultra cards on Samsung devices whilst having the 'bloatware' version of Dropbox installed... Why? I have absolutely no clue.. But since removing Dropbox everything seems to be working okay.. Around 5 hours daily testing over the last couple of days and haven't had a single eject in the process... Admittedly the cause seems to be completely unrelated.... But, alas... Hope this may help someone with the same issue in the future.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...