5,593,248 Members 32,337 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Music turns on when earphones plugged in - how to disable?

Tip us?
 
Skeleton
Old
(Last edited by Skeleton; 9th December 2013 at 05:24 PM.)
#1  
Skeleton's Avatar
Member - OP
Thanks Meter 12
Posts: 91
Join Date: Dec 2005
Location: Vancouver, BC
Default [Q] Music turns on when earphones plugged in - how to disable?

Whenever I plug in my headphones into Note-3, the Samsung Music app starts and plays. Personally, I prefer to not have it start. I usually use a different music app or audio book player.

Is there a way (presumably in settings somewhere) of disabling Music app from starting when earphones are plugged in?

================

SOLVED.
See bottom of thread.
 
donalgodon
Old
#2  
donalgodon's Avatar
Senior Member
Thanks Meter 617
Posts: 3,675
Join Date: Jan 2010
Quote:
Originally Posted by Skeleton View Post
Whenever I plug in my headphones into Note-3, the Samsung Music app starts and plays. Personally, I prefer to not have it start. I usually use a different music app or audio book player.

Is there a way (presumably in settings somewhere) of disabling Music app from starting when earphones are plugged in?
You have to disable Page Buddy service.

I also found this annoying.
PHONE: Samsung Galaxy Note 3 (SM-N900)
ROM: [KitKat][4.4.2]Stock N900UBUDNB2 FEB 14, 2014 CF-Auto-Root
RADIO: N900UBUDNA1
KERNEL: Stock
RECOVERY: CWM 6.0.4.7
WARRANTY BIT: 1


STATUS: Flashing Addict!





Quote:
“He who answers a matter before he hears it, It is folly and shame to him.” Proverbs 18:13
 
Skeleton
Old
#3  
Skeleton's Avatar
Member - OP
Thanks Meter 12
Posts: 91
Join Date: Dec 2005
Location: Vancouver, BC
Quote:
Originally Posted by donalgodon View Post
You have to disable Page Buddy service.

I also found this annoying.
That's it! I now remember it on my previous Note-2.

Oh wait - I can't find it. Does it still exist on the Note-3?
(If so, can you lead me to where it is hidden?)

Thanks ...
 
donalgodon
Old
#4  
donalgodon's Avatar
Senior Member
Thanks Meter 617
Posts: 3,675
Join Date: Jan 2010
Quote:
Originally Posted by Skeleton View Post
That's it! I now remember it on my previous Note-2.

Oh wait - I can't find it. Does it still exist on the Note-3?
(If so, can you lead me to where it is hidden?)

Thanks ...
I think there is a setting for it somewhere in the ROM itself, as I recall, but I always just completely remove the service with Titanium Backup.
PHONE: Samsung Galaxy Note 3 (SM-N900)
ROM: [KitKat][4.4.2]Stock N900UBUDNB2 FEB 14, 2014 CF-Auto-Root
RADIO: N900UBUDNA1
KERNEL: Stock
RECOVERY: CWM 6.0.4.7
WARRANTY BIT: 1


STATUS: Flashing Addict!





Quote:
“He who answers a matter before he hears it, It is folly and shame to him.” Proverbs 18:13
The Following User Says Thank You to donalgodon For This Useful Post: [ Click to Expand ]
 
ShadowLea
Old
#5  
ShadowLea's Avatar
Senior Member
Thanks Meter 611
Posts: 2,878
Join Date: Dec 2010
Location: Enschede, The Netherlands
There was a setting for it, but I can't seem to locate it anymore. The setting still exists in N7player though.

Mine doesn't do this, perhaps because I disabled MusicFX, Adapt Sound and Multimedia UI Service Layer? Or the setting in N7 enforces it?

Send From My Samsung Galaxy Note 3 N9005 Using Tapatalk
SM-N9005 International Galaxy Note 3, DBT NB7 Stock Unrooted.

Never underestimate the power of stupid people in large groups.

The simplest solutions are often the cleverest. They are also usually wrong.
The Following User Says Thank You to ShadowLea For This Useful Post: [ Click to Expand ]
 
Skeleton
Old
#6  
Skeleton's Avatar
Member - OP
Thanks Meter 12
Posts: 91
Join Date: Dec 2005
Location: Vancouver, BC
I have disabled the PageBuddyNotiSvc" in Application Manager. I had to also delete the service's cache, then it worked.

This works - YEAH!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...