Default [Q] Cyanogenmod nightlies failing to install (status 7)

I have CyanogenMod successfully installed on my first gen fire.

I am running the 10.2 nightlies andn have run into a problem with the last 3 versions 8,9,10th December.

I download and hit install, it reboots to TWRP and the install fails (Status 7).

I then have to install a previous version from the 29th Nov which works fine......

Anyone have a clue what is the problem?

Thanks in advance