5,604,686 Members 37,030 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Recovery Broken (Secure Booting Error)

Tip us?
 
shmigadiga
Old
(Last edited by shmigadiga; 7th December 2013 at 06:05 AM.) Reason: Update with exact error code
#1  
Junior Member - OP
Thanks Meter 3
Posts: 19
Join Date: Sep 2012
Question [Q] Recovery Broken (Secure Booting Error)

Hello, I had been using my AT&T g2 with TWRP 2.6.3.2 just fine for months but since attempting to upgrade to 2.6.3.3 (for Kit Kat) I have been unable to boot into recovery. I tried to do the automatic install as shown in http://forum.xda-developers.com/show....php?t=2472223 and began to receive a "secure booting error" upon attempting to boot to recovery, followed by what I assume to be a download mode where the screen turns black and connects as an unformatted drive to my computer. I then attempted manual install on my phone via terminal emulator as described in aforementioned thread with no luck, and have even downloaded the CWM recovery from the play store, installed that recovery, and still have the same problem with being unable to boot into recovery. I have attempted to flash the recovery file with flashify as well, to no avail.

After getting stuck at the black screen instead of a welcome recovery menu, I am able to hold down my power button, shut off my phone, and reboot into CM where everything works just fine.

I'd appreciate help as to how I might be able to restore my recovery partition. Thank you.

Edit: The exact error is "Boot Certification Verify" which appears in the upper left corner on the LG logo boot screen.

The TWRP Recovery Auto Installer shows this in the command prompt when trying to install:
Quote:
Install Recovery...

1410 KB/s (67688 bytes in 0.046s)
4189 KB/s (67020 bytes in 0.015s)
3696 KB/s (8931328 bytes in 2.359s)

/dev/block/platform/msm_sdcc.1/by-name/aboot: cannot open for read: Permission d
enied
Unable to chmod /data/local/tmp/aboot.img: No such file or directory

[+] loki_patch v2.1
[-] Failed to open /data/local/tmp/aboot.img for reading.

[+] loki_flash v2.0
[-] Failed to open aboot for reading.

Press any key to Reboot into recovery or disconnect USB cable from PC now...
 
strose09
Old
#2  
Senior Member
Thanks Meter 38
Posts: 252
Join Date: Oct 2010
Location: New Jersey
I'm having the same issue for my ATT G2. Someone please help.

Sent from my KFTT using xda app-developers app
 
shmigadiga
Old
#3  
Junior Member - OP
Thanks Meter 3
Posts: 19
Join Date: Sep 2012
Thumbs up Fixed!

Follow the thread attached below this response and you'll be all set. The link to the LG flash tools is the incorrect file, but a quick google search will give you what you need (top 3 results for me proved fruitful).

I restored to the stock firmware following the instructions of the thread and then rooted, installed TWRP, and flashed CM quite easily.




The Lg mobile launcher technique described below led to nothing but wasted time, as the application would crash on windows 8.1 & XP. I do not advise even attempting this one, linked below.

 
seventy5
Old
(Last edited by seventy5; 11th December 2013 at 02:40 AM.)
#4  
Junior Member
Thanks Meter 2
Posts: 13
Join Date: Aug 2012
I currently have this identical problem as described in OP. Is there any way to fix this without having to completely restore stock, reroot and install twrp again? It seems somewhat overkill.

EDIT: Nevermind, I figured it out. I found the old version of twrp 2.6.3.2 still on my computer. Re-flashed that, using the option 2 from http://forum.xda-developers.com/show....php?t=2449670. It then worked fine when I rebooted in to recovery. I then flashed the zipped version of 2.6.3.3 from within twrp.
Tags
2.6.3.3, recovery, recovery broken, secure booting error, twrp
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes