5,600,571 Members 33,412 Now Online
XDA Developers Android and Mobile Development Forum

[TOOL] Unyaffs for Android

Tip us?
 
_n0p_
Old
#1  
_n0p_'s Avatar
Senior Member - OP
Thanks Meter 1821
Posts: 2,556
Join Date: Apr 2009
Location: Kiev
Prompt [TOOL] Unyaffs for Android

Hi.
Recently i had to restore on (now my wife's) Streak nandroid backup in StreakMod.
For some reason data.img got restored only partially, though i was sure that backup completed fine.
And desktop unyaffs tool has given two errors on bad file records.
--
Fortunately this tool (unyaffs fork?)
https://github.com/ehlers/unyaffs
was able to fully unpack my "corrupted" data.img
Compiled it for android (static), restored data ok and attached to this post.
Hope this will help someone.
--
Using is simple - copy via adb in recovery mode to /tmp, allow execution. cd /data. /tmp/a-unyaffs $DATAFILENAME
--
Not posting in "General Android" as i think nobody uses custom recovery that uses yaffs now .
--
WBR, Sergei.
Attached Files
File Type: zip a-unyaffs.zip - [Click for QR Code] (188.5 KB, 47 views)
The Following 2 Users Say Thank You to _n0p_ For This Useful Post: [ Click to Expand ]
 
besony
Old
#2  
besony's Avatar
Senior Member
Thanks Meter 13
Posts: 212
Join Date: May 2009
Location: Pune
Quote:
Originally Posted by _n0p_ View Post
Hi.
Recently i had to restore on (now my wife's) Streak nandroid backup in StreakMod.
For some reason data.img got restored only partially, though i was sure that backup completed fine.
--
Using is simple - copy via adb in recovery mode to /tmp, allow execution. cd /data. /tmp/a-unyaffs $DATAFILENAME
--
WBR, Sergei.
So, it would have been a good solution for my problem too?

My problem posted here

Quote:
Just as I had almost accepted - that my Streak's inner SD had some issues - I was reading up on this thread.

Last time the streak worked super (as ever) - it just gave bunch of FCs, restarted okay.. and then just DIED!
I could not boot..
I could not restore any nandroids..

I was getting "could not mount /data " error while trying to wipe data/partition.
Same while restoring nandroid backups.

But - today- I did as many 'wipes' as I could.. and then did a factory reset..

-- and VOILA!--

Phoenix bootanimation came on.. and the phone was back!!
Developers _ FTW!
My phone - is like a woman! So unpredictable & random - and beats logic, anyday!
 
_n0p_
Old
#3  
_n0p_'s Avatar
Senior Member - OP
Thanks Meter 1821
Posts: 2,556
Join Date: Apr 2009
Location: Kiev
No, it' absolutely unrelated.
The Following User Says Thank You to _n0p_ For This Useful Post: [ Click to Expand ]
 
besony
Old
#4  
besony's Avatar
Senior Member
Thanks Meter 13
Posts: 212
Join Date: May 2009
Location: Pune
Arrow Yikes..

Quote:
Originally Posted by _n0p_ View Post
No, it' absolutely unrelated.
But, thank you for your reply..
I found a post somewhere whuch had exactly the same problem as mine.. will track what that guy did..

Thanks,

Sony.
Developers _ FTW!
My phone - is like a woman! So unpredictable & random - and beats logic, anyday!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes