Unhappy [Q] Frustrated: Keep having to re-flash ROMs after rebooting.

Hello first of all I would like to thank all the great developers for the great ROMs out there.

Second I would like to warn everyone that this is a "first world problem rant" that I'm about to write up with a legit frustration I have.

I have a rooted Samsung Galaxy S4 from ATT and the only reason I got this phone over any other Android phone is the great camera and the screen.

I absolutely hate TouchWiz. It's bloated, slow and painfully ugly (to me). For this reason I decided to try out Flashing roms.

For the last couple of weeks (months maybe?) I have been using Cyanogenmod 10.1 stable with not many problems. Mostly camera issues but no biggie.

My frustration is the following: CyanogenMod has had two stable updates for my phone to go from 10.1 to 10.2 and, though it flashes perfectly, every time I reboot the phone the phone gets stuck on the "Samsung Custom (lock)" screen and I am forced to go into TWRP and reflash 10.1+Gapp from my SD carfd.. This happens EVERY TIME. With CM10.1 I can restart the phone just fine by the way. It's 10.2 and other Roms that make get stuck on the Samsung Custom (lock) screen.

So i decided to try out Gummy ROM because Kit Kat

I put the ROM in my SD card, Formated, Wiped and Installed. Worked like a charm until the camera wasnt working that well. I read the forums and said to restart to fix the camera.. Guess what?...AGAIN....Stuck on Samsung Custom (lock) screen.

My frustrations is that pretty much EVERY Rom that I have tried minus CM10.1 has done this to me and I have no idea what I'm doing wrong.

I have tried battery pulls, waiting 30 seconds, wiped dalvik, cache, etc. Fixed Permissions....everything and I have to reflash the ROMs almost 99% of the time unless I use CM10.1. I am tired of reading forums to fix this so here I am asking for your help.

/endrant


I have no idea what else to do so any help would be great.

INFO:

Current ROM: Gummy 1.1-11-21-13-UNOFFICIAL

Android 4.4

Baseband version
I3377UCUAMDL

Kernel Version
3.4 g0-Elite-Kernel-ga719cb

Build Number:
KRT16S

Google Apps:
Gapps-Kk-20131113.Zip

TWRP Version
I have no idea and I'm not about to restart phone and go through the pain of reflashing the ROM again as I just did. I will punch so many babies if I have to do this again!'


Thanks for listening.