5,606,201 Members 32,831 Now Online
XDA Developers Android and Mobile Development Forum

[HELP] Problems with updating hboot, RUU, super CID, S-OFF,

Tip us?
 
Mythic~
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 5
Join Date: Nov 2012
Question [HELP] Problems with updating hboot, RUU, super CID, S-OFF,

I have an HTC One S (duh) with CM10, hboot 1.14, S-ON, no superCID at the moment.

I want to flash a new ROM, but everything either needs me to have S-OFF (superCID) at the least, or a newer hboot.

So in order to update my hboot, I was under the impression that I needed to get back on stock ROM. I tried that - got some error while running the RUU. I also don't remember why I got that impression.

I can't do superCID because my phone, while showing up under fastboot devices, says device not connected with ADB shell. I already tried reinstalling the adb drivers, no luck.

I can't do either S-OFF (facepalm or moonshine).

So, should I just give up at this point?
 
tivofool
Old
#2  
tivofool's Avatar
Senior Member
Thanks Meter 165
Posts: 530
Join Date: Jun 2012
Quote:
Originally Posted by Mythic~ View Post
I have an HTC One S (duh) with CM10, hboot 1.14, S-ON, no superCID at the moment.

I want to flash a new ROM, but everything either needs me to have S-OFF (superCID) at the least, or a newer hboot.

So in order to update my hboot, I was under the impression that I needed to get back on stock ROM. I tried that - got some error while running the RUU. I also don't remember why I got that impression.

I can't do superCID because my phone, while showing up under fastboot devices, says device not connected with ADB shell. I already tried reinstalling the adb drivers, no luck.

I can't do either S-OFF (facepalm or moonshine).

So, should I just give up at this point?
You will need to be S-off for the ROMs that require 2.16 HBoot.

The other ROMs (require 2.15 HBoot) You will be ok with S-on. Just have to remember to fastboot flash the boot.img before installing the ROM.
But first you need to update your firmware to 2.15.

So keep trying RUU.exe trying one that will work with your CID. Look for RUU that have JB that will bring you the 2.15 Hboot and Jelly Bean update.
Remember to lock your bootloader before running the RUU (since you are S-on)
 
Mythic~
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 5
Join Date: Nov 2012
Quote:
Originally Posted by tivofool View Post
You will need to be S-off for the ROMs that require 2.16 HBoot.

The other ROMs (require 2.15 HBoot) You will be ok with S-on. Just have to remember to fastboot flash the boot.img before installing the ROM.
But first you need to update your firmware to 2.15.

So keep trying RUU.exe trying one that will work with your CID. Look for RUU that have JB that will bring you the 2.15 Hboot and Jelly Bean update.
Remember to lock your bootloader before running the RUU (since you are S-on)
Yeah, I've done all that for the RUU. I'm 100% sure I have the right one, but when I run it it gives me an error. When I get home I'll try again.
 
tomk11
Old
#4  
Junior Member
Thanks Meter 2
Posts: 15
Join Date: Aug 2013
Quote:
Originally Posted by Mythic~ View Post
I have an HTC One S (duh) with CM10, hboot 1.14, S-ON, no superCID at the moment.

I want to flash a new ROM, but everything either needs me to have S-OFF (superCID) at the least, or a newer hboot.

So in order to update my hboot, I was under the impression that I needed to get back on stock ROM. I tried that - got some error while running the RUU. I also don't remember why I got that impression.

I can't do superCID because my phone, while showing up under fastboot devices, says device not connected with ADB shell. I already tried reinstalling the adb drivers, no luck.

I can't do either S-OFF (facepalm or moonshine).

So, should I just give up at this point?
In terms of Supercid and s-off. You can get supercid on roms that aren't stock, but you need supercid for s-off. So my phone was stock, then i flashed cm10, then i gained supercid, then s-off, then i could put whatever rom i fancied on (in that order). I had HBOOT 2.15.

Dunno if it helps because it sounds like you are using windows and i use linux but i had problems with adb too. Which I fixed by using the equivalent to "run as administrator".
 
Mythic~
Old
(Last edited by Mythic~; 9th December 2013 at 02:26 AM.) Reason: Just kidding.
#5  
Junior Member - OP
Thanks Meter 1
Posts: 5
Join Date: Nov 2012
I found the root of my problems - apparently my HTC drivers installation was corrupted, so most processes would get to a point but be unable to continue because of some error having to do with the drivers.

I reinstalled them, so hopefully I'll have some success with rumrunner.

Just kidding. Rumrunner says I'm "not rooted" even though I am running a custom ROM with unlocked bootloader.
The Following User Says Thank You to Mythic~ For This Useful Post: [ Click to Expand ]
 
Mythic~
Old
#6  
Junior Member - OP
Thanks Meter 1
Posts: 5
Join Date: Nov 2012
So I'm S-OFF, but the RUU refuses to work. (I'm trying to get a kitkat-based ROM and i need hboot 2.15 for that)

I always get the error:

Error Code: -5001 : 0x80070002
Error Information:
>SetupNew\setup.cpp (142)
PAPP:
PVENDOR:
PGUID:
$
@Windows 7 / Server 2008 R2 Service Pack 1 (7601)
IE Version: 9.11.9600.16476

Any help?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Google Glass Now Open to Anyone… with $1500 to Spend (Update: Not Anymore)

Google Glass, which recently received its official update … more

Android 4.4.2 OTA Now Available for the Verizon Droid DNA

A couple of days ago, we talked about how the Android 4.4.2 upgrade for the HTC … more

UnbelovedHosts Uses Xposed to Block Unwanted Connections

First popularized by mvps, hosts-based ad blocking has become the de facto standard … more