Default [Q] Switched out gallery apps and hard-bricked my phone

Update: The 100th or so time I tried to boot into recovery, miraculously it worked!!! I have no idea why. I reflashed and did a soft wipe, and now all is good. The phone's internal memory only had about 225 MB of storage space left, so maybe that caused the problem, or maybe not. Thanks to everyone who tried to think of possible fixes.


Hi, I did a really stupid thing last night. I backed up with TB and uninstalled my gallery app to try another one that I didn't like. (I have QuickPic installed, as well as third-party camera apps.) So I uninstalled that one and then tried to restore the original gallery app again with TB. For some reason the install hung. What I should have done was force-close TB and install the APK again directly, but instead I rebooted the phone. Or tried to. As it turned out, I hard-bricked it.

The battery icon displays. When I try to turn on the power, the Samsung logo displays and then the phone turns off again. I can't boot into recovery or download mode at all. When I connect to my PC via USB, I get a boot-looping pop-up on the PC taskbar: "Found New Hardware/SAMSUNG Mobile MTP Device." The device screen stays black. ADB won't start. I reinstalled the Samsung drivers just in case, but no love. The Windows device manager doesn't show any problem with the drivers. Odin does recognize the device up to a point: a yellow box lights up and there's an "added" message, but nothing more. At this point, all I can think of to do is get hold of a jig as soon as I can and pray that I can get into download mode and connect to Odin. I am (or was...) rooted and running CM 10.2 stable.

How likely is it that the jig will work? And does anyone have any other suggestions? I'd really appreciate them. I don't have a landline, and it's a bummer not to be able to make calls so close to Christmas.

Thanks a lot for your help. I really appreciate it!