Default DInc Gingerbread Upgrade problem and Froyo CWM Errors - Can't Mount SDcard and Cache

This is a follow-up to my "Problem Installing Gingerbread; currently have Froyo 2.2 s-off" post.Thought I'd repost with an updated title that better reflects progress made so far in restoring my DInc.

- DInc purchased new; rooted; s-off; Incredikernal; Convert2Ext4_no_data_limit_normal_dalvik mod; CM7.2 (was on Tiny's CM10.1)
- Phone died while listening to music (plugged in to 5volt 2amp Nexus7 charger); would not boot beyond white HTC Incredible screen.
- Tried to restore nandroid backup.
- Upon booting to recovery received numerous “can’t mount” errors in ClockworkMod (CWM).
- Could not access zip from sdcard "E:Can't mount /sdcard/". (Note: also can't mount /emmc/)
- Tried loading image from nandroid backup via HBOOT, with no success

- Flashed stock Froyo 2.2 via HBOOT successfully. DInc is working!
- Regained root via unrevoked3 successfully
- Flashed CWM via HBOOT successfully


1. Still can’t access sdcard
a. Confirmed card is formatted FAT32
b. SDCard seems OK – flashing image via HBOOT works and sdcard can be read from Froyo
c. Tried "fastboot oem enableqxdm 0" followed by “fastboot reboot” commands. Programs ran but still no access.
d. Tried to re-format a different sdcard in Froyo, card got corrupted!
- Formatted FAT32 on PC, inserted in phone
- “Unmount SDcard” and "Format SDcard" in Froyo, could not “Mount sdcard” in Froyo.
- PC says that SDcard needs to be formatted
e. Help please!

2. CWM mount errors:
a. ClockworkMod Recovery v2.5.1.2
E:Can't mount /dev/block/mmcblk0p2 (File exists)
E:Can't mount /cache:recovery/command
E:Can't mount /dev/block/mmcblk0p2 (File exists)
E:Can't mount /cache:recovery/log
E:Can't mount /dev/block/mmcblk0p2 (File exists)
b. ClockworkMod Recovery v5.0.2.0
E:Can't mount /cache/recovery/command
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
c. Are these errors possibly related to bad partitions: Should I try Parted per topic 6433 at cyanogenmod forum (sorry, can’t post links)?
d. Are these errors possibly caused by the Convert2Ext4 mod, and should I try to run that again if/when I get my sdcard mounted?
e. Are these errors probably hardware related, and I stop looking for a software fix?

3. Gingerbread
a. I tried to load Gingerbread images (from pvillecomp, and also a version from cmlusco) via HBOOT; but no luck (boot loop).
b. I tried to load the Gingerbread RUU (from pvillecomp), but no luck. Perhaps a HTC Sync issue, but have not yet reloaded HTC Sync.
c. If I can't overcome mounting problems, I would at least like to be running Gingerbread vs Froyo (hence title of original thread).
d. Help please!

Thanks all,