5,606,530 Members 34,641 Now Online
XDA Developers Android and Mobile Development Forum

Has anyone found a solution to the dead PC/USB connection?

Tip us?
 
Haphim
Old
#1  
Senior Member - OP
Thanks Meter 25
Posts: 344
Join Date: Apr 2009
Default Has anyone found a solution to the dead PC/USB connection?

Running CM 10.1.3, I can no longer connect the phone to my PC (Win 7, x64). There is no acknowledgement from either the phone or the PC that a data connection has been made (other than that it was charging). I used to be able to connect okay, but now it's not working.

Searching around, this is apparently a common issue with the S4. I've made various attempts at dealing with this, including re-installing the Samsung drivers, with no success. I don't even know if it's specific to CM, or the phone's hardware/firmware.

Has anyone found a solution for this problem?
 
willieamm
Old
#2  
Junior Member
Thanks Meter 0
Posts: 15
Join Date: Oct 2012
Hope this works for u. I had an issue connecting my Galaxy S4 as well. Here's the solution I found.

Click the phone icon to access the dial pad and type *#0808#
A menu will appear once the last character is entered.

Choose : AP on upper section and for USB Setting choose MTP.

Reboot the device. Good luck.

Credits to sucah for this solution.
 
Haphim
Old
#3  
Senior Member - OP
Thanks Meter 25
Posts: 344
Join Date: Apr 2009
Quote:
Originally Posted by willieamm View Post
Hope this works for u. I had an issue connecting my Galaxy S4 as well. Here's the solution I found.

Click the phone icon to access the dial pad and type *#0808#
A menu will appear once the last character is entered.

Choose : AP on upper section and for USB Setting choose MTP.

Reboot the device. Good luck.

Credits to sucah for this solution.

I can't get USSD codes to work. I get an error "Connection problem or invalid MMI code". Adding a comma at the end doesn't fix it. As soon as I can get past this problem, I'll give that solution a try. Thanks!
 
rbedell
Old
#4  
rbedell's Avatar
Senior Member
Thanks Meter 141
Posts: 373
Join Date: Jul 2012
Quote:
Originally Posted by Haphim View Post
Running CM 10.1.3, I can no longer connect the phone to my PC (Win 7, x64). There is no acknowledgement from either the phone or the PC that a data connection has been made (other than that it was charging). I used to be able to connect okay, but now it's not working.

Searching around, this is apparently a common issue with the S4. I've made various attempts at dealing with this, including re-installing the Samsung drivers, with no success. I don't even know if it's specific to CM, or the phone's hardware/firmware.

Has anyone found a solution for this problem?
My computer has USB 3.0 equipped with fast charge, ASUS. The app updated and screwed my usb connections to any chargeable device. I wound up having to remove the app and then reinstall the drivers. Don't know if that might be an issue with your computer but it's with a check.

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 
Haphim
Old
#5  
Senior Member - OP
Thanks Meter 25
Posts: 344
Join Date: Apr 2009
I discovered that those USSD codes are Samsung specific, which means that they only work on the stock ROM. In CM, they are invalid.

Any other ideas?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes