Question Help, cannot receive MMS no matter what I try...

I should start out by saying that I have a Telus I317M N7105 Note 2. Other than rooting the stock 4.0, the only rom I have installed is ProBam (many times over) and to my knowledge it does not touch the modem files or the APN settings. I just recently learned that while I can send MMS messages (attachments to texts), I have possibly NEVER been able to receive them. If people send me a text message, I get it. If they send me a text message with a picture attached, from their end it sends normally with no errors but I never see it or any sign of it.

At first I thought it was the APN settings, but after trying approximately 7 trillion combinations nothing fixes it. I can break things all I want, but the best I can do to fix it is to get back to square one - namely, me being able to send but not receive. And before anyone points me to a link with Telus APN settings, please pm me your home address so I can come and poop in your kid's sandbox. Trust me, I know how many google results there are for such a thing because I HAVE BEEN TO ALL OF THEM.

In desperation I wondered if at some point my modem files were b0rked, even though ProBam wouldn't have touched them and neither have I. Of course I had my original modem/EFS/EMEI stuff backed up from the very beginning, needless to say it doesn't work. My phone was shipped with the I317MVLBMA3 modem, after digging around for a while I flashed the newest Rogers I317MVLUCMK5 modem. What I learned is that the Canadian modem files are NOT cross compatible. When I flashed the newer modem, my primary APN settings screen (which has 3 radio options: Koodo SP, Telus SP, and Telus SP Tether) was firmly locked onto the 'Telus SP Tether' and nothing would make the normal one (Telus SP) stick. Which wasn't a problem, because the phone worked, and so did normal text messages. What wouldn't work was MMS in either direction, no matter what the settings. Also, unlike the stock setup, it was difficult to make changes to the APN settings 'stick'. If you hit the back key, they would revert - which they don't do on stock! If you hit settings, there is a 'save' option, which WILL make them stick, but of course since I never got MMS to work who knows what is really happening?

And now for the saddest news of all: Using the new Rogers modem, my phone had NOTICABLY better reception. I live in Northwest BC, and there are more holes in the cell net around here than a Canucks goalie (sorry, inside joke). With this modem, a lot of those holes were filled, in fact the signal strength was better across the board. A shadow is still a shadow, but in the fuzzy areas I had solid reception. LE SIGH. I should mention that I don't have LTE where I live, but I do have 4G.

And so, I had to flash back to the original modem, where once again NOTHING I do makes it so I can receive MMS messages. I saw some oddball suggestions, there is a 'settings' menu in the actual SMS/MMS app (again, I am using the stock one that I guess is from CM, but I have used Chomp and others and they all work the same), some people have said that unchecking 'auto receive messages' made miracles happen for them, but it didn't make a difference to me.

The phone itself knows that I am not on a stock rom, so people who say that the APN settings are completely separate from the rom are wrong. If I hit 'reset to defaults' it changes the APN type to 'default,supl,mms'. Again, I am going to stress this one more time - I have tried EVERY SINGLE SETTING that I have found on the internet. Pro tip: you don't need spaces, and you don't need to reboot (although I have tried that too between every change, of course).

So PLEASE, FOR THE LOVE OF GOD AND ALL THAT IS HOLY, someone give me an idea as to what I can try next?! This is insane, it almost feels like a faulty sim card or something. I don't know if I have EVER received an MMS message, and it was only when someone insisted that they sent me a pic that I knew there was even something up. Please, anything...

Phone: Master Race Note 2 (I317M)
Rom: W03 SlimKat V12 [t0lte]
Kernel: Devil2-2.3.2-t0lte-DUAL-20140102

Tablet: Nexus 7 2013 (flo)
Rom: SinLessROM v3.1.0
Kernel: ElementalX-N7-2.3