5,595,918 Members 31,294 Now Online
XDA Developers Android and Mobile Development Forum

Compiling error ../repo/android.git is HTML?

Tip us?
 
penser
Old
#1  
Senior Member - OP
Thanks Meter 97
Posts: 550
Join Date: Jan 2013
Default Compiling error ../repo/android.git is HTML?

I just got everything working for the first time finally and I'm not sure how to get around this. Every compiling/building guide says to execute the following with appropriate URL and branch, but it gives me the (second) below.
Code:
repo init u git://github.com/user/android.git b cm-10.2
Code:
mike@crunchbang:~/android/omni$ repo init -u git://github.com/mike64221/android.git -b android-4.4
/home/mike/bin/repo: line 1: syntax error near unexpected token `newline'
/home/mike/bin/repo: line 1: `<!DOCTYPE html>'
I just can't figure it out. Could anyone help?

Yes, I am (attempting) to build Omni.

Hopefully there'll be some possible solutions by morning so I can go ahead and let it work during school.

Sent from my MB886 using Tapatalk
Devices:
LG G2 - Stock ATT 4.4.2

Atrix HD - Stock ATT 4.1.1
 
penser
Old
#3  
Senior Member - OP
Thanks Meter 97
Posts: 550
Join Date: Jan 2013
Quote:
Originally Posted by GermainZ View Post
You downloaded the repo utility wrongly. I'm guessing from a dead link (the HTML file is your repo file, not android.git). Look for the correct location and download it again.
What repo utility? The repo Linux package? If so, where should I download it from? I got the current version from the default Crunchbang/Debian repositories.

Sent from my MB886 using Tapatalk
Devices:
LG G2 - Stock ATT 4.4.2

Atrix HD - Stock ATT 4.1.1
 
GermainZ
Old
#4  
GermainZ's Avatar
Forum Moderator
Thanks Meter 3848
Posts: 4,066
Join Date: Aug 2012
Quote:
Originally Posted by penser View Post
What repo utility? The repo Linux package? If so, where should I download it from? I got the current version from the default Crunchbang/Debian repositories.

Sent from my MB886 using Tapatalk
I doubt a system package installed itself to your home directory.
Code:
/home/mike/bin/repo
 
penser
Old
(Last edited by penser; 20th December 2013 at 05:13 AM.)
#5  
Senior Member - OP
Thanks Meter 97
Posts: 550
Join Date: Jan 2013
Quote:
Originally Posted by GermainZ View Post
I doubt a system package installed itself to your home directory.
Code:
/home/mike/bin/repo
Must have copied the link wrong. (Using this guide http://www.techlila.com/compile-andr...m-source-code/) Now I'm getting
Code:
bash: /home/mike/bin/repo: Permission denied
EDIT: Nevermind, got it. Just had to do some digging at http://source.android.com/source/downloading.html.

EDIT: Now getting
Code:
fatal: manifest 'default.xml' not available
fatal: remote caf not defined in /home/mike/android/omni/.repo/manifests/default.xml
will be checking responses periodically, can't try for around 6-7 hours.

EDIT: Reading it now, I need to add a remote for "caf". Yay, more digging.

Looked through the default.xml in class and found the caf remote with no fetch, so I'll have to fix that sometime, then hopefully it'll be all good.

Got home, fixed it up, got it working and now there are issues with the omni repos (another person got the same error as me). Hopefully either overnight build or during-school build works. Thanks for your help!
Devices:
LG G2 - Stock ATT 4.4.2

Atrix HD - Stock ATT 4.1.1
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes