Default [Q] Cruz Velocity t510/Allwinner a10 'Damaged sd card' in CM10 & AOKP

Here is a little background;
I'm new to the android world and this is my first tablet using it. I received the tablet under the terms that its mine, if I can fix it. THE TABLET So the research begins. The original problem with the tablet: everything would crash after unlock screen, including loader. The tablet does not have any kind of visual recovery mode using the hard buttons. At this time I did not know about any of the tools that I probably could of used to save the stock firmware. When I hit Google with "Cruz velocity micro t510" not much came up, so I spent about a day trying all sorts of different terms with that. There was not even a place to download firmware from cruz, they say wifi is mandatory to upgrade, from within the tablet... I finally ran into a post somewhere where someone said the cruz t510 is an allwinner a10 in disguise. They went on to say that all you need to do is use Livesuit and flash 'sun4i_crane_T05a_v1.5_mxc6225' img from eken website then from there you can use the compatability zip and upgrade to cm10.
So all was good. The t05a firmware there works perfect on it, like the guy said. I kept that on there for a day before I went on to CyanogenMod.


Here is where I am stuck; (Tired of googling, please help )
I decide to try AOKP and CM10 using http://forum.xda-developers.com/show....php?t=1821398 and one for AOKP too with t05a-v1_compatibility_1.2.x.zip. And http://forum.xda-developers.com/show....php?t=2189640 for recovery mode. I learned how to setup and use ADB with command prompt here.
So I install CWM using ADB shell and reboot into recovery using the sh file. I first folowed the steps to install AOKP and all goes smoothly until I reboot.

I get a notice saying "Damaged SD Card, You may need to reformat" and I realize that it is talking about the internal disk space. I try to reformat and the same notice will appear again or I will have to go in Settings>Storage and Mount SDcard, only to be told no, it is damaged. So I got scared and re-flash back to the eken stock firmware with livesuit. Guess what, sdcard mounted and working again. Then I go on to repeat the upgrade but with CM10 this time. Same result.
I have gone back to the stock image and retried many times. I tried with all three partition versions of that CWM I use, even though I knew it was 10, or so adb shows. I also tried partitioning and formmating with CWM, many times, each a little different.


Short, Sweet, and Simple version;

THE TABLET
Eken a90 stock firmware using livesuit -> SDCard works fine
CM10 or AOKP with t05a-v1_compatibility_1.2.x.zip using CWM 6.0.2.8 -> SDCard damaged


If anyone could help I would very much appreciate it. I need a break from all the research, I'm going to play gtav and hope someone has a solution for me.