5,594,653 Members 32,862 Now Online
XDA Developers Android and Mobile Development Forum

Erroneous Battery Indicator

Tip us?
 
andoruB
Old
#1  
Member - OP
Thanks Meter 2
Posts: 37
Join Date: Oct 2011
Default Erroneous Battery Indicator

Something is wrong with the way the phone indicates the battery charge. For example, when I play on my Milestone and the battery is getting close to 20%, after a few minutes it drops to 15% in a few minutes then immediately to 5% and 1%. Also I noticed that even though it indicates it only has 1% battery left, it still is able to run for 20-30 more minutes (perhaps less) with the screen on. Also putting it to charge right after it indicates 5-1% boosts it up instantly to 20% or sometimes even 60% which is weird... I've tried multiple times to reset the battery stats (which doesn't do anything) or I've followed another guide that specifies to charge the battery completely, restart then pull out the battery once the Motorola logo shows up with the charging cable still plugged in. That worked before and the battery would return somewhat to normal, but now that doesn't work anymore.
So is there anything I can do to fix this? I'm using Kabladan's CyanogenMOD 7.2.4f (if anyone has other suggestions for a better ROM for this phone please do let me know =D )
 
Erovia
Old
#2  
Erovia's Avatar
Senior Member
Thanks Meter 213
Posts: 709
Join Date: Sep 2012
I have the same problem with my stone, and I'm pretty sure it's the battery's fault and the phone and rom has nothing to do with it.

My guess is one or more cells are worned out in the battery so it doesn't store any capacity but it still reports full capacity to the phone.
Phone: Nexus 4
ROM: ParanoidAndroid 4+
Kernel: hells-Core
Recovery: MultiROM
--------------------------------------------------------------------------------------------------------------------------
Tablet: Nexus 7
ROM: SlimKat 4+
Kernel: LeanKernel
Recovery: MultiROM
--------------------------------------------------------------------------------------------------------------------------
Phone: Motorola Milestone A853 ROM: CyanogenMod 9.1.0d Recovery: Open Recovery MiniMod by -FuFu-
 
andoruB
Old
#3  
Member - OP
Thanks Meter 2
Posts: 37
Join Date: Oct 2011
It could be that it's the battery's fault, but in my case it's a bit the reverse of yours, a lot less battery is reported that it should.
Also, how is CM 9.1.0d working out for you? Does it have any improvements over 7.2.4f? =)
Too bad Kabladan abandoned all progress on his Milestone ROMs, they were quite useful for this deadbeat unsupported phone.
 
Erovia
Old
#4  
Erovia's Avatar
Senior Member
Thanks Meter 213
Posts: 709
Join Date: Sep 2012
I'm satisfied with it.
I do the "heavier" tasks on my N7, so I use my MS mainly for internet thethering, calling, etc. After some days it gets a bit laggy (it can be within 3-4 days or 2-3 weeks, depending on usage), but after a restart it gets fast again, so it is not a big deal. I'm using CM9 because I use a few apps that requires at least ICS and basically it is more user-friendly than GB.

I recommend you to try it, test the different settings (zRam/swap,etc) and see if it suits your needs.
Phone: Nexus 4
ROM: ParanoidAndroid 4+
Kernel: hells-Core
Recovery: MultiROM
--------------------------------------------------------------------------------------------------------------------------
Tablet: Nexus 7
ROM: SlimKat 4+
Kernel: LeanKernel
Recovery: MultiROM
--------------------------------------------------------------------------------------------------------------------------
Phone: Motorola Milestone A853 ROM: CyanogenMod 9.1.0d Recovery: Open Recovery MiniMod by -FuFu-
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes