Default restore softbrick

Hi
I think my problem is in worst situation ever.
First, I was on CM11.
Then I heard VZW GS3 finally got 4.3 update, so I just went back to 4.1.2 official firmware.
Then my problem started.
I got that update, and then boot was successful.
However, all of my game data and pictures were gone.
So I tried to fix that because I thought that game data and pictures were still remain at some where.
Why?
cause the memory usage showed to me it was 4GB left.
it was same amount as when I was in 4.1.2 with all the data and pictures.
so, I tried to go back to 4.1.2, but I couldn't.
And I was using CWM latest version for GS3, but OTA disable it.
So every time that I trying to go to recovery mod, it shows "System software not authorized blahblahblah..."
Anyway, then I try to boot that system nomarly.
I thought it will going to boot, but it shows Samsung Galaxy S3 logo, then booted again.
then shows "System software not authorized by Verizon Wireless blahblahblah..."
Then I try to flesh CWM 6.0.1.2 recover by odin 3.07, but it keep shows Failed.
I look up to phone error message was
Secure check failed : recovery.
It didn't installed.
So, I fleshed into stock recovery, and it installed perfectly.
So I did factory reset, and wipe caches, but still same.
It is not booting.
keep showing
System software not authorized.........
is any solution that I can do with now?

(sorry for my bad English.)