5,603,591 Members 36,054 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Cannot install CM 10.2 or 11 - I9500 | Error 7 and Error 0

Tip us?
 
om.thelostone
Old
(Last edited by om.thelostone; 21st December 2013 at 05:13 AM.) Reason: Underlined
#1  
Member - OP
Thanks Meter 2
Posts: 50
Join Date: Feb 2011
Default [Q] Cannot install CM 10.2 or 11 - I9500 | Error 7 and Error 0

I am inserious trouble with no installable ROM.

I had downloaded the latest CM 10.2 stable, as well as the CM 11 nightly for Galaxy S4 I9500 international - which are product version jfltexx as per CM site.
But my ro.build.product and ro.product.device is ja3g.

I followed all steps and at the step of installing, I got an Error 7: Installation aborted.
I am using Philz touch recovery. Was using CWM Cofface version previously which gave the same error.

After googling around, I found that its because of an assert equal check that is done while installing it in recovery, in which my device does not match CM. (Since mine is ja3g and CM is jfltexx)
The solution was either add my device in the META-INF\com\google\android\updater-script, or delete this updater script from CM zip, so that the check is not performed at install.

But then it gives Error 0, since the CM zip is now modified. Also, turning of signature verification is still giving this error.

I am now with no ROM. Please help.
Can I change my ro.product.device and ro.build.product to jfltexx, using adb? Would that not cause any problems in future? How to do that?
Or can you suggest a custom ROM which is available for my build ja3g?

My Samsung fingerprint is:
samsung/ ja3gxx / ja3g:4.2.2 / JDQ39 / I9500XXUAMDK:user / release-keys
 
HANDSY
Old
#2  
Senior Member
Thanks Meter 298
Posts: 726
Join Date: Apr 2012
Can you confirm which phone model you have please. I have the I9505 which is jfltexx. If you have the I9500 then you need the rom for that model

Sent from my GT-I9505 using XDA Premium 4 mobile app
 
om.thelostone
Old
#3  
Member - OP
Thanks Meter 2
Posts: 50
Join Date: Feb 2011
I have I9500. Now that is the international version. In CM downloads, that was available as jfeltxx.
So now I have an I9500 with only Philz recovery on it, no ROM.
Its rooted.
What do you suggest to get it up and running with a 4.3 or 4.4? - Other than using Odin to flash the default firmware.
 
om.thelostone
Old
#4  
Member - OP
Thanks Meter 2
Posts: 50
Join Date: Feb 2011
I have I9500. Now that seems the international version. In CM downloads, that was available as jfeltxx. So it was my mistake to think that jfeltxx was for me.

So now I have an I9500 with only Philz recovery on it, no ROM, since I wiped and cleaned it.
Its rooted.

What do you suggest to get it up and running with a custom 4.3 or 4.4? - Other than using Odin to flash the default firmware.
 
om.thelostone
Old
#5  
Member - OP
Thanks Meter 2
Posts: 50
Join Date: Feb 2011
I have I9500. Now that seems the international version. In CM downloads, that was available as jfeltxx. So it was my mistake to think that jfeltxx was for me.

So now I have an I9500 with only Philz recovery on it, no ROM, since I wiped and cleaned it.
Its rooted.

What do you suggest to get it up and running with a custom 4.3 or 4.4? - Other than using Odin to flash the default firmware.
 
HANDSY
Old
#6  
Senior Member
Thanks Meter 298
Posts: 726
Join Date: Apr 2012
If you only have a recovery on your phone you have to flash a rom via PC odin. Only you can choose which rom is best for you.

Sent from my GT-I9505 using XDA Premium 4 mobile app
 
rajeshwar.singh.maini
Old
#7  
Junior Member
Thanks Meter 0
Posts: 8
Join Date: Oct 2013
Quote:
Originally Posted by om.thelostone View Post
I am inserious trouble with no installable ROM.

I had downloaded the latest CM 10.2 stable, as well as the CM 11 nightly for Galaxy S4 I9500 international - which are product version jfltexx as per CM site.
But my ro.build.product and ro.product.device is ja3g.

I followed all steps and at the step of installing, I got an Error 7: Installation aborted.
I am using Philz touch recovery. Was using CWM Cofface version previously which gave the same error.

After googling around, I found that its because of an assert equal check that is done while installing it in recovery, in which my device does not match CM. (Since mine is ja3g and CM is jfltexx)
The solution was either add my device in the META-INF\com\google\android\updater-script, or delete this updater script from CM zip, so that the check is not performed at install.

But then it gives Error 0, since the CM zip is now modified. Also, turning of signature verification is still giving this error.

I am now with no ROM. Please help.
Can I change my ro.product.device and ro.build.product to jfltexx, using adb? Would that not cause any problems in future? How to do that?
Or can you suggest a custom ROM which is available for my build ja3g?

My Samsung fingerprint is:
samsung/ ja3gxx / ja3g:4.2.2 / JDQ39 / I9500XXUAMDK:user / release-keys
By international they mean i9505 idk why but the ROM is not for i9500
It works fine with i9505


Sent from my GT-I9500 using XDA Premium 4 mobile app

Tags
i9500, ja3g, ja3gxx
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

When Using GitHub, Don’t Skimp on Commit History

GitHub has become the epicenter of most open source development work that is posted … more

Verizon Droid DNA to Receive 4.4.2 KitKat + Sense 5.5 OTA This Thursday

The HTC Droid DNAis Verizon’s close cousin to the JapaneseHTC … more

Lucid Browser is Small, Lightweight, and Open Source

If there is one application category that certainly isn’t lacking in Android,and … more