Default Another Bricked Tab

Hello,

Device: Asus Transformer Prime TF201

In a bit of a pickle, I flashed a recovery and it succeeded then tried to boot which worked, the touch interface wouldn't work so I rebooted and thought it'd be a good idea to clear the Cache. Now I cant get to recovery or Android OS and my tablet is stuck at the Asus boot screen, It is now in APX mode.

It appears in Windows 7's Device Manager as Asus Transformer Prime APX Interface (after I installed the drivers). It doesn't appear in the adb devices list and as APX under 'Unspecified' in devices and printers. I have had a look on forums and online but there are so many variation and its a bit overwhelming.

I sent it into the retailer I bought it from and said I "turned it on after not using in awhile and it get stuck at the Asus Logo, long story short they contacted Asus and were told that the device was unlocked and they coild fix it at my cost or I could try.

Should I just get them to fix it or am I able to fix it myself?