5,595,000 Members 38,944 Now Online
XDA Developers Android and Mobile Development Forum

Eclipse stuck at Launching 100%

Tip us?
 
juggernautrises
Old
(Last edited by juggernautrises; 21st December 2013 at 06:21 PM.) Reason: formatting
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Dec 2013
Unhappy Eclipse stuck at Launching 100%

Hi all,

I’ve just started picking up Android development for a personal project I’m working on. It’s a very simple app that just sends color values to a webservice. However, testing this app has been a nightmare. I’m using Eclipse with a Galaxy S4 and the first time I uploaded my program to the device, it worked pretty much as I intended. I noticed some typos in my Toasts so I went back to fix them and tried to rebuild and reupload and Eclipse was got stuck at “Launching myProject: (100%) and refuses to move beyond that. I’ve done a Clean and rebuild and tried unplugging my device and it uploads maybe 1 out of every 20 attempts. I literally spent about three hours trying to fix this last weekend and even did a removal of Eclipse and the Android SDK and started fresh but no dice. Running adb devices from the command line shows my device but it hangs when I run adb install. This app and project would have been done several days ago if not for these issues. Anyone have any advice?

Note: I don't want to use the emulator as it takes forever to boot up and is incredibly slow
 
Scripts
Old
#2  
Member
Thanks Meter 7
Posts: 54
Join Date: Dec 2013

 
DONATE TO ME
I suggest that you make sure all the bugs are fixed with your application, Eclipse runs smoothly and your phone isn't running anything in the background other than your app. The problem probably is just Eclipse being slow so make sure everything is in the right folder and hasn't been moved and try running and debugging your application. Best of luck to you.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes