Default [Q] 8.9 Jem LTE and Bluetooth

I have managed upon an LTE version of the Kindle Fire HD 8.9 . Some research here and elsewhere makes it pretty clear that all the third Party ROMs for this device are still waiting for support for Bluetooth, GPS, and LTE. Not wanting to muddy up the discussion at
http://forum.xda-developers.com/show....php?t=2391776
with a question that brings little to Hashcode et al's very much appreciated efforts, I decided to post here.
In my possibly unique situation, I have no need for the LTE functionality of the device. It was purchased cheap since the IMEI code is blacklisted with AT&T. However, I would very much like to use Bluetooth with it. Looks like Stock ROM is it until a breakthrough occurs? Or did I miss something out there?