5,595,428 Members 48,298 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Only acces on sd-card thru usb-mass storage

Tip us?
 
cluster56
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2013
Location: Heppen
Default [Q] Only acces on sd-card thru usb-mass storage

Hi there,

I have a HTC wildfire [buzz] -s off, I rooted it, got cm7 on it. Now the problem is, the SD-card worked perfectly, and after a while the phone doesn't recognize my SD-card anymore. At some point it eats 4g away from my partitionated 8g SD. Then suddenly i have no SD at all anymore atleast on software cm7 running, however when I boot into recoverymode i can only have acces to that sd card while in usb mass storage device thru my pc. But can't install any apps since I was gonna install 'gapps' when i noticed SD was not recognized by cm7.... I formated mulitple times using sd-format and minitool partion a few times with different partitions one fat-32 other ext2. now 4g formatted just fat 32.

Can anybody give me a work around? I'm fairly new to rooting. So keep it a bit simple if possible.
Thanks and kind regards.
 
anttaz
Old
#2  
Senior Member
Thanks Meter 14
Posts: 299
Join Date: Nov 2009
Location: Doncaster

 
DONATE TO ME
Quote:
Originally Posted by cluster56 View Post
Hi there,

I have a HTC wildfire [buzz] -s off, I rooted it, got cm7 on it. Now the problem is, the SD-card worked perfectly, and after a while the phone doesn't recognize my SD-card anymore. At some point it eats 4g away from my partitionated 8g SD. Then suddenly i have no SD at all anymore atleast on software cm7 running, however when I boot into recoverymode i can only have acces to that sd card while in usb mass storage device thru my pc. But can't install any apps since I was gonna install 'gapps' when i noticed SD was not recognized by cm7.... I formated mulitple times using sd-format and minitool partion a few times with different partitions one fat-32 other ext2. now 4g formatted just fat 32.

Can anybody give me a work around? I'm fairly new to rooting. So keep it a bit simple if possible.
Thanks and kind regards.
Try Using SD Formater tool I used in windows fixed loads of SD card Problems for me the link: http://panasonic.jp/support/global/cs/sd/download/

Now I use Gparted in linux as no longer use Windows ever
The Following User Says Thank You to anttaz For This Useful Post: [ Click to Expand ]
 
cluster56
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2013
Location: Heppen
already did that mate, got that tool but didn't resolve the problem
thx for the reply tho
 
cluster56
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2013
Location: Heppen
Default sd-card problem

well, the phone does recocgnize when I remove the card.... strangely enough, not when I put it back inside
 
the X Machine
Old
#5  
the X Machine's Avatar
Member
Thanks Meter 126
Posts: 84
Join Date: Jun 2013
Location: irbid

 
DONATE TO ME
Quote:
Originally Posted by cluster56 View Post
Hi there,

I have a HTC wildfire [buzz] -s off, I rooted it, got cm7 on it. Now the problem is, the SD-card worked perfectly, and after a while the phone doesn't recognize my SD-card anymore. At some point it eats 4g away from my partitionated 8g SD. Then suddenly i have no SD at all anymore atleast on software cm7 running, however when I boot into recoverymode i can only have acces to that sd card while in usb mass storage device thru my pc. But can't install any apps since I was gonna install 'gapps' when i noticed SD was not recognized by cm7.... I formated mulitple times using sd-format and minitool partion a few times with different partitions one fat-32 other ext2. now 4g formatted just fat 32.

Can anybody give me a work around? I'm fairly new to rooting. So keep it a bit simple if possible.
Thanks and kind regards.
when did this started because it happened to me after i partitioned my sdcard try deleting all partitions then see what happens
 
cluster56
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Dec 2013
Location: Heppen
Default problem is solved

Quote:
Originally Posted by the X Machine View Post
when did this started because it happened to me after i partitioned my sdcard try deleting all partitions then see what happens
Well it seems the partition I made was lost, I ran minitool partition lost and it did the trick, found 4gb partition back, deleted all and made a new one, sd-card works again on phone, me happy....

Thanks for the reply's tho
Kind regards
Cluster
 
the X Machine
Old
#7  
the X Machine's Avatar
Member
Thanks Meter 126
Posts: 84
Join Date: Jun 2013
Location: irbid

 
DONATE TO ME
Quote:
Originally Posted by cluster56 View Post
Well it seems the partition I made was lost, I ran minitool partition lost and it did the trick, found 4gb partition back, deleted all and made a new one, sd-card works again on phone, me happy....

Thanks for the reply's tho
Kind regards
Cluster
and me want to see a thx

The Following User Says Thank You to the X Machine For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Add Swipe Utilities to Your App with SimpleFingerGestures Library

Gestures have become an increasingly important element in smartphone UI … more

Android App Review: Lock it Down with Lockdown Pro – XDA Developer TV

Our smartphones are our lives. They store our contacts, emails, … more

Get the AOSP Lock Screen on Your ICS-Powered Samsung Device

Android is the only popular mobile operating system that allows users, … more

Motorola Droid RAZR HD and M to Receive KitKat in a “Few More Weeks”

Verizon and Motorola shocked us all back in November when … more