5,599,478 Members 39,870 Now Online
XDA Developers Android and Mobile Development Forum

HELP trouble with root

Tip us?
 
Bublik2002
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 18
Join Date: Jan 2011
Default HELP trouble with root

I had an s4 with ota 4.3 mk2 installed and Knox already tripped. I rooted it using cfauto root, flashed cwm and flashed virgin ROM 3.1. The phone works awesome but I no longer have root for some reason. When I click on superSu it tells me that the binary is not installed
 
baseballfanz
Old
#2  
baseballfanz's Avatar
Senior Member
Thanks Meter 1708
Posts: 6,684
Join Date: Oct 2010
Location: Sugar Land TX
Try flashing the latest SuperSU on recovery.

☞ Sent from here☜🙈🙉🙊
**************
 
Bublik2002
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 18
Join Date: Jan 2011
Quote:
Originally Posted by baseballfanz View Post
Try flashing the latest SuperSU on recovery.

☞ Sent from here☜🙈🙉🙊
I tried that and it didn't fix it
 
aamir123
Old
#4  
Senior Member
Thanks Meter 116
Posts: 846
Join Date: Dec 2010
Quote:
Originally Posted by Bublik2002 View Post
I tried that and it didn't fix it
You may have to wipe factory reset, wipe system then reflash rom, if you want you can nandroid as a backup, TiBu prolly won't work without root.
 
xdapowerapps
Old
#5  
xdapowerapps's Avatar
Senior Member
Thanks Meter 190
Posts: 527
Join Date: Jul 2008
Quote:
Originally Posted by Bublik2002 View Post
I tried that and it didn't fix it
Try the flashable Superuser app from Koushik and if it does work, then update SuperSu.

.
.
< - - - - - Please hit the button if I helped.

Unlocked TMO SGS4, SGH-M919, WarpDrive KK 4.4.2, Ktoonsez Kernel, PhilZ Touch Recovery.

HUGE THANKS TO rovo89 FOR HIS XPOSED FRAMEWORK. List of Xposed Modules
.
.
 
Misterjunky
Old
#6  
Misterjunky's Avatar
Senior Member
Thanks Meter 1875
Posts: 3,935
Join Date: Jan 2011
Location: Bakersfield, California

 
DONATE TO ME
Thumbs up re: root issues

Quote:
Originally Posted by Bublik2002 View Post
I had an s4 with ota 4.3 mk2 installed and Knox already tripped. I rooted it using cfauto root, flashed cwm and flashed virgin ROM 3.1. The phone works awesome but I no longer have root for some reason. When I click on superSu it tells me that the binary is not installed
First Re-Flash CF-Autoroot.

Once you have root open SuperSU in your phone and as in the picture
below make sure you checkmark the boxes you see in this screenshot.


That's what I did a while back and never had root issues since then.

Good luck!
Have a great day, enjoy!

Don't forget it takes less time to click the "THANKS" button than to type "thank you".
(unless you type very fast).



 
Bublik2002
Old
#7  
Junior Member - OP
Thanks Meter 1
Posts: 18
Join Date: Jan 2011
Quote:
Originally Posted by Misterjunky View Post
First Re-Flash CF-Autoroot.

Once you have root open SuperSU in your phone and as in the picture
below make sure you checkmark the boxes you see in this screenshot.


That's what I did a while back and never had root issues since then.

Good luck!
Tried both koushik superuser and updating superSU V 1.86. Neither have me root privelages
 
Bublik2002
Old
#8  
Junior Member - OP
Thanks Meter 1
Posts: 18
Join Date: Jan 2011
Quote:
Originally Posted by Misterjunky View Post
First Re-Flash CF-Autoroot.

Once you have root open SuperSU in your phone and as in the picture
below make sure you checkmark the boxes you see in this screenshot.


That's what I did a while back and never had root issues since then.

Good luck!
It won't let me get into that menu because it says super use binary not installed and if it has to do with 4.3 to go to forums
 
Misterjunky
Old
#9  
Misterjunky's Avatar
Senior Member
Thanks Meter 1875
Posts: 3,935
Join Date: Jan 2011
Location: Bakersfield, California

 
DONATE TO ME
Thumbs up re: root issue

Quote:
Originally Posted by Bublik2002 View Post
It won't let me get into that menu because it says super use binary not installed and if it has to do with 4.3 to go to forums
Have you already flashed a custom kernel since
you upgraded to the official 4.3 Jellybean rom?

If not, @jovy23 's stock-modified kernel might fix the root issue
if you are on the 100% stock kernel right now.

Here is the download link for the stock-modified 4.3 M919 kernel:
http://www.androidfilehost.com/?fid=23252070760972765

Before you flash this kernel it would be best if you odin flashed
cf-autoroot but un-tick the "auto reboot" option in odin before flashing.

After it's flashed remove usb cable & power down the phone using the
power button then power the phone on into recovery.

Then in recovery flash @jovy23 's kernel and all should be good.



Good luck!
Have a great day, enjoy!

Don't forget it takes less time to click the "THANKS" button than to type "thank you".
(unless you type very fast).



 
Bublik2002
Old
#10  
Junior Member - OP
Thanks Meter 1
Posts: 18
Join Date: Jan 2011
Quote:
Originally Posted by Misterjunky View Post
Have you already flashed a custom kernel since
you upgraded to the official 4.3 Jellybean rom?

If not, @jovy23 's stock-modified kernel might fix the root issue
if you are on the 100% stock kernel right now.

Here is the download link for the stock-modified 4.3 M919 kernel:
http://www.androidfilehost.com/?fid=23252070760972765

Before you flash this kernel it would be best if you odin flashed
cf-autoroot but un-tick the "auto reboot" option in odin before flashing.

After it's flashed remove usb cable & power down the phone using the
power button then power the phone on into recovery.

Then in recovery flash @jovy23 's kernel and all should be good.



Good luck!
Thanks just reflashing cf auto root through odin fixed it.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...