5,605,250 Members 38,407 Now Online
XDA Developers Android and Mobile Development Forum

Cheap ($10) MHL 2.0 to HDMI Review

Tip us?
 
haza12d
Old
#11  
haza12d's Avatar
Senior Member
Thanks Meter 53
Posts: 443
Join Date: Nov 2007
Location: Gotham
Just heard back from customer service. They say that it is supposed to work with and cannot be used without a power supply. I told them that it worked without a power supply and even showed them the video. They insisted that the unit I received wasn't defective. I'll be returning this and I'm picking up the Samsung one instead.

Sent from my SM-N900V using Tapatalk
 
Chase.XDA
Old
#12  
Chase.XDA's Avatar
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Dec 2013
Location: Phoenix
Quote:
Originally Posted by haza12d View Post
Just heard back from customer service. They say that it is supposed to work with and cannot be used without a power supply. I told them that it worked without a power supply and even showed them the video. They insisted that the unit I received wasn't defective. I'll be returning this and I'm picking up the Samsung one instead.

Sent from my SM-N900V using Tapatalk
The one I received does not work at all, even with the power connected. I'm not sure if I should try and get a replacement or just get a refund since they state it DOES NOT work without power, even though the video shows that it can.


Quote:
Originally Posted by Customer Service
Cable must be used with power supply.
Do not support the phone has root ROM.
Not Support Contract Smartphones,Such as the AT&T, Sprint, Verizon Cellphones
 
babyshanks
Old
#13  
babyshanks's Avatar
Senior Member - OP
Thanks Meter 90
Posts: 251
Join Date: Oct 2013
Location: Minneapolis
Quote:
Originally Posted by CZroe View Post
The Apple charger is only 1200mA when used with an Apple device. It's probably outputting 450 or 500mA (USB standard) because it doesn't recognize the charge capabilities of the connected device. Unfortunately, they only support proprietary signaling for Apple device charging capabilities. You should have known considering how notorious Apple is for such things! Granted, a standardized way for microUSB chargers didn't exist when they first needed it, but I doubt they ever added support in any of the revisions. FWIW, the HP TouchPad uses proprietary signaling as well.
Didn't know that proprietary thing was still an issue, figured it'd be the same since I do get 1200mah (according to galaxy charging current) charging from it using the N3. I'll grab my roommates s2 charger when I get a chance and see if it makes a difference.

Quote:
Originally Posted by haza12d View Post
Just heard back from customer service. They say that it is supposed to work with and cannot be used without a power supply. I told them that it worked without a power supply and even showed them the video. They insisted that the unit I received wasn't defective. I'll be returning this and I'm picking up the Samsung one instead.

Sent from my SM-N900V using Tapatalk
Quote:
Originally Posted by Chase.XDA View Post
The one I received does not work at all, even with the power connected. I'm not sure if I should try and get a replacement or just get a refund since they state it DOES NOT work without power, even though the video shows that it can.
Sorry to hear that guys, guess it's a really inconsistent product. I've had a good experience using it, but I wouldn't have recommended it knowing it had could have such issues.Customer service for me was quick to replace my first one which didn't charge but worked without a power adapter. Also on the product description it says that it works without a power adapter for some phones "Supports use without connecting the charger with some smartphones." so maybe you could use that as an argument if you didn't decide to just return it.
Thanks for the F-Shack, Love Dirty Mike and the Boys.
I'm a sucker for the thanks button
The Following User Says Thank You to babyshanks For This Useful Post: [ Click to Expand ]
 
CZroe
Old
#14  
Senior Member
Thanks Meter 89
Posts: 674
Join Date: Nov 2011
Location: Newnan, GA
I tried the Apple charger and I get 1200mA too. I guess they did add standard signaling for device charge capabilities. Once I even measured 1800mA (immediately went back down to 1200mA)!
Sony Ericsson Xperia PLAY 4G (R800at) Xperia PLAY (R800x) with Sony Ericsson MBW-150 Bluetooth wristwatch, Parrot SK4000 motorcycle helmet Bluetooth kit, and Looxcie 2 LX2 wearable Bluetooth camera/headset.

HP TouchPad 32GB running Cyanogen Mod 9.
 
haza12d
Old
#15  
haza12d's Avatar
Senior Member
Thanks Meter 53
Posts: 443
Join Date: Nov 2007
Location: Gotham
They are sending me a new one. Hope this one works like the one in the video
 
haza12d
Old
#16  
haza12d's Avatar
Senior Member
Thanks Meter 53
Posts: 443
Join Date: Nov 2007
Location: Gotham
I just received the replacement and it still needs power to function. I'll be getting my $10 back and grab me the Samsung one. I heard theirs didn't need a power supply.

Sent from my SM-N900V using Tapatalk
 
christianpeso
Old
#17  
christianpeso's Avatar
Senior Member
Thanks Meter 79
Posts: 377
Join Date: Sep 2007
Quote:
Originally Posted by haza12d View Post
I just received the replacement and it still needs power to function. I'll be getting my $10 back and grab me the Samsung one. I heard theirs didn't need a power supply.

Sent from my SM-N900V using Tapatalk
100% confirmed that the Official Samsung MHL cable works without an extra power cord.
 
aznmode
Old
#18  
Senior Member
Thanks Meter 747
Posts: 3,943
Join Date: Jun 2007
There's a lot of these circling around eBay. Made to look like Samsung. Even has the Samsung logo and Samsung box. But just like previous mhl it still requires power. Complained to the seller and maybe a few others dud as well so they've taken it off their site. Maybe due to copyright thing as well.

In my review it, it's not a bad unit but some TVs it will only out put 720p but less stutter. At home on my Samsung it outputs at 1080p but stutters.

I wonder how well the OEM version handles 1080p. And I do like that OEM ones do not require power.

Sent from my SM-N900T using Tapatalk
Don't forget to give thanks if I've helped you in anyway...

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes