5,606,409 Members 33,415 Now Online
XDA Developers Android and Mobile Development Forum

S4 not registering on T-Mobile

Tip us?
 
imsosa
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
Unhappy S4 not registering on T-Mobile

Hi, i've been using my S4 since May of this year.. It was originally bought in Canada (rogers) and I have been using it on Tmobile in Las Vegas since May... There were no problems until the other day. Out of now where it stopped working. It does not read sim. I went to the Tmobile store and got a replacement sim but still no luck. The sim works in another phone just fine...

Does anyone why it won't connect to the network? There was an update on my phone about a week ago and i did update it to the latest software.
Very frustrating. hope someone can help.

thanks
 
sum1one
Old
#2  
Senior Member
Thanks Meter 38
Posts: 191
Join Date: Dec 2013
Location: WNY
Quote:
Originally Posted by imsosa View Post
Hi, i've been using my S4 since May of this year.. It was originally bought in Canada (rogers) and I have been using it on Tmobile in Las Vegas since May... There were no problems until the other day. Out of now where it stopped working. It does not read sim. I went to the Tmobile store and got a replacement sim but still no luck. The sim works in another phone just fine...

Does anyone why it won't connect to the network? There was an update on my phone about a week ago and i did update it to the latest software.
Very frustrating. hope someone can help.

thanks
Do you use a custom rom???? I had a problem like that a few days ago. I had to flash a different "radio" MK2 and then my phone started working fine again.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes