5,593,587 Members 38,736 Now Online
XDA Developers Android and Mobile Development Forum

[How To For Sprint] Fix Persistent Voicemail Notification after Flashing New ROM

Tip us?
 
HaveAnEpiphany
Old
#1  
Junior Member - OP
Thanks Meter 5
Posts: 19
Join Date: Sep 2010
Location: Sarasota, FL

 
DONATE TO ME
Exclamation [How To For Sprint] Fix Persistent Voicemail Notification after Flashing New ROM

I recently upgraded to a 4.4 ROM on my Sprint SGS3. After flashing the new ROM and getting settled in to use it, I was unable to get rid of the annoying Sprint voicemail notification. It said I had 7 voicemails.

I've used Google Voice for my voicemail for several years, so I didn't believe that notification was true. But I decided to disable Google Voice and dial in to the Sprint system just to see if anything had ended up in there. It was empty.

Try as I might, nothing would eliminate the voicemail notification, and there was no way to "swipte it away."

Not finding anything related to the SGS3, I ran a site-wide search and came across this thread for the Nexus 5.

I've been a fan of Ghost Commander for a long time, so I used it instead of FX Explorer, which is what PaulB007 (the author of that thread) used. Ghost Commander has a "Root" mode built in, which was required in order for me to successfully navigate to the folder and file mentioned in that thread.

ROOT is required for this fix. But since it happened to me after flashing a new ROM, presumably that's obvious.

On my device, here's what I did:

Step 1. In Ghost Commander, from the "Home" menu, select "Root mode". If prompted, grant Ghost Commander "superuser" privileges (I did this for only 10 minutes to keep myself from bumping something during another session later).

Step 2. Make sure you've navigated to the root:/# location. Select the /data folder. Inside it, select the /data folder again. Ghost Commander should show your current folder as root:/data/data#

Step 3. Tap the "com.android.phone" folder, then find the "shared_prefs" folder. Find the file named "com.android.phone_preferences.xml" and long-press it. Ghost Commander's context menu that appears has an "edit" button which you can press to make edits to the file. That's what I did. If you want to be extra careful, you could "copy" that file and make yourself a backup, which would probably be wise. What can I say? I like to live on the edge sometimes.

Step 4. This is where what I did differed greatly from what PaulB007 did. The file on my device was fairly long, so rather than replace it's entire contents, I located the line that showed the voice mail count. It read:

Code:
<int name="vm_count_key_cdma" value="7" />
Ah ha! The 7 voicemails!

I changed it to read:

Code:
<int name="vm_count_key_cdma" value="0" />
Then I hit the menu button on my device, chose "Save" then hit the back button to return to the folder.

I skipped most of the other steps mentioned by PaulB007, but I did follow his 11th step:

Quote:
Step 11: go into your notifications on the top of your screen and long press on the voicemail notification. Tap "App Info." Force stop your phone application so that the notification disappears up top.
That was as far as I needed to go... the notification disappeared after force stopping the phone app. It has not reappeared!!

A big thanks to PaulB007 for posting the fix on his Nexus 5 device.

As an aside, I don't know if it makes any difference, but the ROM I recently flashed is based on Cyanogenmod. Something similar has happened in the past with some other ROMs, but I've always been able to clear the voicemail notification with typical fixes (rebooting, reconfiguring Google Voice, etc.). This time, it obviously called for more extreme measures.
The Following 3 Users Say Thank You to HaveAnEpiphany For This Useful Post: [ Click to Expand ]
 
PaulB007
Old
#2  
Senior Member
Thanks Meter 65
Posts: 574
Join Date: Dec 2008
Quote:
Originally Posted by HaveAnEpiphany View Post
I recently upgraded to a 4.4 ROM on my Sprint SGS3. After flashing the new ROM and getting settled in to use it, I was unable to get rid of the annoying Sprint voicemail notification. It said I had 7 voicemails.

I've used Google Voice for my voicemail for several years, so I didn't believe that notification was true. But I decided to disable Google Voice and dial in to the Sprint system just to see if anything had ended up in there. It was empty.

Try as I might, nothing would eliminate the voicemail notification, and there was no way to "swipte it away."

Not finding anything related to the SGS3, I ran a site-wide search and came across this thread for the Nexus 5.

I've been a fan of Ghost Commander for a long time, so I used it instead of FX Explorer, which is what PaulB007 (the author of that thread) used. Ghost Commander has a "Root" mode built in, which was required in order for me to successfully navigate to the folder and file mentioned in that thread.

ROOT is required for this fix. But since it happened to me after flashing a new ROM, presumably that's obvious.

On my device, here's what I did:

Step 1. In Ghost Commander, from the "Home" menu, select "Root mode". If prompted, grant Ghost Commander "superuser" privileges (I did this for only 10 minutes to keep myself from bumping something during another session later).

Step 2. Make sure you've navigated to the root:/# location. Select the /data folder. Inside it, select the /data folder again. Ghost Commander should show your current folder as root:/data/data#

Step 3. Tap the "com.android.phone" folder, then find the "shared_prefs" folder. Find the file named "com.android.phone_preferences.xml" and long-press it. Ghost Commander's context menu that appears has an "edit" button which you can press to make edits to the file. That's what I did. If you want to be extra careful, you could "copy" that file and make yourself a backup, which would probably be wise. What can I say? I like to live on the edge sometimes.

Step 4. This is where what I did differed greatly from what PaulB007 did. The file on my device was fairly long, so rather than replace it's entire contents, I located the line that showed the voice mail count. It read:

Code:
<int name="vm_count_key_cdma" value="7" />
Ah ha! The 7 voicemails!

I changed it to read:

Code:
<int name="vm_count_key_cdma" value="0" />
Then I hit the menu button on my device, chose "Save" then hit the back button to return to the folder.

I skipped most of the other steps mentioned by PaulB007, but I did follow his 11th step:



That was as far as I needed to go... the notification disappeared after force stopping the phone app. It has not reappeared!!

A big thanks to PaulB007 for posting the fix on his Nexus 5 device.

As an aside, I don't know if it makes any difference, but the ROM I recently flashed is based on Cyanogenmod. Something similar has happened in the past with some other ROMs, but I've always been able to clear the voicemail notification with typical fixes (rebooting, reconfiguring Google Voice, etc.). This time, it obviously called for more extreme measures.
Hey man, are the settings sticking for you still? My success with this method seems to be ROM dependent and refuses to stick sometimes.


BAM BAM POW POW SHOOTER!!
 
PaulB007
Old
#3  
Senior Member
Thanks Meter 65
Posts: 574
Join Date: Dec 2008
Quote:
Originally Posted by PaulB007 View Post
Hey man, are the settings sticking for you still? My success with this method seems to be ROM dependent and refuses to stick sometimes.

Edit: seems the "<string name="vm_number_key_cdma">xxxxxxxxxxx</string>" lone is important for the nexus 5 at least. You'll have to let me know if it made any difference for this phone.


BAM BAM POW POW SHOOTER!!
 
HaveAnEpiphany
Old
#4  
Junior Member - OP
Thanks Meter 5
Posts: 19
Join Date: Sep 2010
Location: Sarasota, FL

 
DONATE TO ME
Quote:
Originally Posted by PaulB007 View Post
Hey man, are the settings sticking for you still? My success with this method seems to be ROM dependent and refuses to stick sometimes.
Well... I'm not entirely sure.

Last night I drove out of range of Sprint's network and "hopped" to a roaming network and back. I happened to look at my phone and noticed the same notification: 7 voicemails. So... I checked the file and found that it still showed my edit:

Code:
<int name="vm_count_key_cdma" value="0" />
Weird. I was expecting to have to make that change again.

So I killed the phone app, and the notification cleared.

Drove back home... same drill (hopping to roaming and back). No new notification.

So it's too early to tell what's up. I haven't flashed a new ROM or anything (nor do I plan to for a while)... so I'm taking a "wait and see" approach. Would love to hear anything you might learn, though.
 
rickshan
Old
#5  
Junior Member
Thanks Meter 2
Posts: 7
Join Date: Nov 2010
I tried it on CyanFox 4.4 and it didn't work.
The Following User Says Thank You to rickshan For This Useful Post: [ Click to Expand ]
 
HaveAnEpiphany
Old
#6  
Junior Member - OP
Thanks Meter 5
Posts: 19
Join Date: Sep 2010
Location: Sarasota, FL

 
DONATE TO ME
Looks like this fix isn't working. The notification keeps returning when hopping to Roaming and on reboots. I had thought perhaps it wasn't related to the ROM, but I'm on CyanFox as well. Time to bring it up over there...

Sent from my SPH-L710 using xda app-developers app
 
shekinahsmoke
Old
#7  
shekinahsmoke's Avatar
Senior Member
Thanks Meter 647
Posts: 1,783
Join Date: Mar 2011
Location: Brooklyn, NY
cant seem to get this to work on 4.4.2 ROM Mokee.
The Following User Says Thank You to shekinahsmoke For This Useful Post: [ Click to Expand ]
 
E-POUND
Old
#8  
Senior Member
Thanks Meter 51
Posts: 116
Join Date: Sep 2010
Location: STL
Try leaving urself a voice mail from another phone. Then go bak and delete it. It should clear everything up.

Sent from my SPH-L900 using XDA Premium 4 mobile app

The Following User Says Thank You to E-POUND For This Useful Post: [ Click to Expand ]
Tags
kitkat, sgs3, voicemail notification
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes