5,604,050 Members 48,105 Now Online
XDA Developers Android and Mobile Development Forum

Looking to root my MK2 S4

Tip us?
 
cpiercew
Old
#11  
Member
Thanks Meter 1
Posts: 39
Join Date: Dec 2013
Location: chantilly
Default trouble rooting GS4 Verizon MK2

using saferoot from Mac using simple instructions, for some reason the script fails. Confirmed adb shell access. Any thoughts?

Thanks in advance.. output below

usermbp:saferoot user$ adb shell
shell@jfltevzw:/ $ exit
usermbp:saferoot user$ sh ./install.sh
--- Samsung i545 VRUEMJ7 Root ---
--- Based on the CVE-2013-6282 exploit by cubeundcube ---

Waiting for device...
Watch your phone. Unlock it and give permission for the install to run.
Sending files to your device...
2363 KB/s (17804 bytes in 0.007s)
3412 KB/s (104800 bytes in 0.029s)
2208 KB/s (13592 bytes in 0.006s)
3248 KB/s (2139595 bytes in 0.643s)
4732 KB/s (1109128 bytes in 0.228s)
293 KB/s (629 bytes in 0.002s)

Starting rooting program.
ro.build.product=jfltevzw
ro.build.id=JSS15J
selinux enforcing known.
Succeeded in getroot!
Remount success!
Copying files..

Removing temporary files...
error: device not found
error: device not found
error: device not found
error: device not found
error: device not found
error: device not found

Rebooting...Please wait.
error: device not found
Waiting for device to re-appear...
Unlock your phone, and when prompted, give SuperSU permission for
'ADB shell' to run.
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
Installing busybox
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found

--- All Finished ---
usermbp:saferoot user$
 
decaturbob
Old
#12  
Senior Member
Thanks Meter 428
Posts: 1,408
Join Date: Mar 2011
Location: Decatur
Quote:
Originally Posted by cpiercew View Post
using saferoot from Mac using simple instructions, for some reason the script fails. Confirmed adb shell access. Any thoughts?

Thanks in advance.. output below

usermbp:saferoot user$ adb shell
shell@jfltevzw:/ $ exit
usermbp:saferoot user$ sh ./install.sh
--- Samsung i545 VRUEMJ7 Root ---
--- Based on the CVE-2013-6282 exploit by cubeundcube ---

Waiting for device...
Watch your phone. Unlock it and give permission for the install to run.
Sending files to your device...
2363 KB/s (17804 bytes in 0.007s)
3412 KB/s (104800 bytes in 0.029s)
2208 KB/s (13592 bytes in 0.006s)
3248 KB/s (2139595 bytes in 0.643s)
4732 KB/s (1109128 bytes in 0.228s)
293 KB/s (629 bytes in 0.002s)

Starting rooting program.
ro.build.product=jfltevzw
ro.build.id=JSS15J
selinux enforcing known.
Succeeded in getroot!
Remount success!
Copying files..

Removing temporary files...
error: device not found
error: device not found
error: device not found
error: device not found
error: device not found
error: device not found

Rebooting...Please wait.
error: device not found
Waiting for device to re-appear...
Unlock your phone, and when prompted, give SuperSU permission for
'ADB shell' to run.
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
Installing busybox
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found
/system/bin/sh: /system/xbin/su: not found

--- All Finished ---
usermbp:saferoot user$
Did u check to see if you are rooted?

Sent from my SCH-I545 using XDA Premium 4 mobile app
S4 powered by hashcode 3.71 safestrap HYPERDRIVE 15 by Sbreen94
 
cpiercew
Old
#13  
Member
Thanks Meter 1
Posts: 39
Join Date: Dec 2013
Location: chantilly
Quote:
Originally Posted by decaturbob View Post
Did u check to see if you are rooted?

Sent from my SCH-I545 using XDA Premium 4 mobile app

Yes, thanks. Wish it was an oversight but it's not rooted. Using Root Checker by Joeykrim, it reports device is not rooted. Also downloaded terminal emulator and checked at prompt on phone.
 
k1mu
Old
#14  
k1mu's Avatar
Senior Member
Thanks Meter 1247
Posts: 1,582
Join Date: Apr 2011
Location: Virginia

 
DONATE TO ME
Quote:
Originally Posted by reaperslay View Post
So I have been looking all over the place these last couple of days and have been finding no real help. I have stock MK2 on my Verizon S4 and have successfully got Saferoot on my phone and when running a root checker it says I have root access. Problem being I am trying to get Clockwork recovery on my phone and then flash to CM11 so I can have 4.4. I have tried using Odin but it fails every time and anything over Odin 3 also will not see my device. I have like 20 tabs open on my computer looking and trying everything I can and I am now lost as what to try next. Has anyone successfully got this to work on MK2 and able to walk me through exactly what I need to do? I need to get this on my phone because everything keeps freezing and crashing and I miss having a custom ROM on my phone. Please help
Please read this: http://forum.xda-developers.com/show....php?t=2578569

It's unfortunate that you didn't read that before flashing.

---------- Post added at 11:00 PM ---------- Previous post was at 10:54 PM ----------

Quote:
Originally Posted by cpiercew View Post
Yes, thanks. Wish it was an oversight but it's not rooted. Using Root Checker by Joeykrim, it reports device is not rooted. Also downloaded terminal emulator and checked at prompt on phone.
The "device not found" stuff is weird. What it means is that your phone dropped the USB connection while in the middle of rooting.\
I've been spending a lot of time tonight re-flashing my phone and tweaking the saferoot script. Give it another try and post in that thread.
My Android devices:
vzw Samsung Galaxy S4 stock MJ7, now rooted!
Samsung Galaxy Tab 2 10.1, also stock but rooted.

VZ Droid Incredible 2 rooted but otherwise stock.
Samsung Galaxy Tab 10.1
 
cpiercew
Old
#15  
Member
Thanks Meter 1
Posts: 39
Join Date: Dec 2013
Location: chantilly
Fixed by reflashing stock MK2 from Kies.

Sent from my SCH-I545 using Tapatalk
Verizon GS4 SCH-I545 MK2 Safestrap 3.71 Hyperdrive RLS12
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Wearables Walkthrough: Tasker on the Samsung Galaxy Gear – XDA Developer TV

The future certainly looks like it is full of wearables. … more

WinDroid HTC Toolkit Lets You Root, Unlock, and Flash ROMs on Various HTC Devices

Plenty of users nowadays have more than one mobile device. … more

When Using GitHub, Don’t Skimp on Commit History

GitHub has become the epicenter of most open source development work that is posted … more

Verizon Droid DNA to Receive 4.4.2 KitKat + Sense 5.5 OTA This Thursday

The HTC Droid DNAis Verizon’s close cousin to the JapaneseHTC … more