Wink Newbie to custom roms.."READ" everything before doing it !!

Hi All

Very new to modding my Transformer Prime TF201 (Android Version 4.1.1)...but think have worked it all out ...after a couple of day and some big headaches !!! lol

Now flashed to HairyBean V 2.31 and very happy with way it runs ....way faster than it used to be on stock rom ...but think probably just a reinstall would of helped but thought may aswell go the whole hog !!I

I first rooted it with a method i found on net where you use Motochopper which worked a treat ...here is a video from youtube -

http://www.youtube.com/watch?v=ggpsVortObY

I then installed Titanium backup and backed up my apps to my external sd card .
Next i tried just doing a factory restore which did make a difference ...reinstall my apps and tried out some tweaks that someone else told me to try -

http://forum.xda-developers.com/show....php?t=2230779

I found the system was a lot better than before ...so was happy with that
But then someone post on my thread that i should probably Unlock my Prime and try some custom Rom's ...but had no idea how to do this .
So i decided Sunday morning to look into this and found a very good write up on how to do this...looked easy enough ...lets unlock it -

http://matthill.eu/android/transform...ybean-nvflash/

I Unlocked it via the method listed without any issue ....did nvflash too which basically was plain sailing till it come to APX mode ....my version of windows (8.1) would not install the drivers no matter what i did ...so gave up and turned to my laptop that uses Vista ...still could not get APX mode working ...then found out you have to hold UP on volume control when powering up lol...drivers installed fine on that and got the files off the prime that i needed to keep if i bricked it ...tried doing in again on windows 8.1 but drivers still would not go in ......back to vista to finish unlocking my prime.

Now i had an Unlocked Prime with Custom Recovery install i decided to try a Rom ....so downloaded Cyanogenmod 10.2 Unofficial and put it on my external sd card ...booted into recovery mode which was coming up as "Flatine CWM version 1.0" i think it said ....but could not get it to see my external sd card (did a backup of OS while on go and removed it off internal storage to pc)....next i tried to update recovery using Rom Manager off Play Store ....it downloaded latest Clockworkmod and installed it ....hit reboot to recovery ....on reboot it just hung at Asus boot screen .....so reset prime by holding power button and it rebooted into OS ...tried rom manager again but still same ....in the end i used Fastboot and install my original recovery .(found out since not to use Rom Manager ..after paying for it !! )

Next step was to try install TWRP which i did via fastboot ...but took a good hour or so to figure that out as it just would not install ...but managed it in the end ....reboot into recovery and all was well now had TWRP which could see my sd card ....did a backup of OS again .

Time to try a Rom ....which was now straight forward ..installed without a problem and rebooted ...but it stuck on the rotating arrow on Cyanogenmod boot screen ...so back into recovery and then decided to wipe internal storage and data etc ...installed rom again and this time it worked ...booted into OS without an issue .....but after playing for a while i did not like it...back to recovery and restored my backup just to see if it worked ok , which it did ....i then thought i would try HaryBean V 2,31-

http://forum.xda-developers.com/show....php?t=2407248

I downloaded the file to sd card , wiped system first,installed it and rebooted ....all was fine as it loaded , then rebooted !....started up again and carried on loading ...this time it worked ....but kept locking up and rebooting ..(it also downloaded an Asus Update and installed itself).....it rebooted about 7 times so in the end decided to flash rom again ....but things got worse, wouldn't load , lockups etc....so back to recovery and try restoring my backup ....but it would not find it ...weird !! i even went back to my Flatline recovery install and that would not see my backup i did with that either ...something had gone wrong big time !!
I then reinstalled TWRP via fastboot and installed CM again , that worked fine and got into OS ...placed my backup from TWRP onto internal storage to see if the TWRP recovery would see it ...but it still couldnt load it ... now starting to get frustrated !!!

Looked into nvflash and restoring the files i had stored on my pc incase of bricking my prime....but could not find anything on the net on how to do it properly...gave up in the end and looking into why hairybean was not working ....i "SHOULD OF READ" the whole web page lol, as stated on there too !! lol
I had not installed the "Upgrade Hairybean 2.31 (4.2.1) Bootloader & TWRP (2.5).zip" ...installed that and tried reloading the rom ........sucess at last !!!!! worked first time , no reboots and all fine .
It was all down to the wrong bootloader installed ....which in theory ...i could of brick it ....very lucky i say !!

But why would my backup OS file not be found by either recovery ? did the Asus update that install cause this ?? good question .
There is a file to downgrade to 4.1.1 bootloader ...i wonder if doing that would allow my backups to work again ?

At moment ...OS is running sweet , very happy with HairyBean so going to leave things alone for a while till a new version come out .

Maybe this writeup might help newbies who are contemplating unlocking their primes ...be carefull and "READ" everything !!

Karl