Sign [Q] catch-22 in TWRP - permissions

Hello people,

First I'd like to thank everyone contributing on this forum, the posts here have made it possible for a beginner like I am to have a rooted phone.
I am posting this after trying in vain to find a solution to an issue I'm having with permissions on my Ascend Y300.

I rooted it and had CM 10.2 running smoothly for over a month while updating to nightly builds. After one of these updates I accidentally did a full advanced wipe in TWRP v2.5.0.1., but re-installed the rom and all seemed well. Then I started having "insufficient space available" notifications when trying to install apps from Google Play, despite having plenty of space available on both the internal and external SD. I reinstalled the rom, wiping only cache and dalvik this time. This time I couldn't download anything due to low space.

Looking into the problem I tried to delete the dump files in \data but when trying to reach that folder, whether via shell or the file manager in CM, I would get denied access due to permissions. I tried through TWRP's file manager and terminal but ran into the same problem.

I did a full system wipe again out of frustration, then tried Fix Permissions in TWRP. Am getting this as a result:

Can't check permissions after Factory Reset.
Please boot rom and try again after you reboot into recovery.
Then I tried to flash the rom I had before, which failed with the following message:

set_perm: some changes failed
E:Error executing updater binary in zip '/sdcard (truncated)
Error flashing zip '/sdcard/cm-10.2.......
I tried to sideload my rom as well, to no avail (permissions error).

Basically, TWRP is telling me that I need to install a rom to fix permissions, but I need to fix permissions to install a rom.

I tried to restore settings in TWRP: clicking the option freezes the phone. Perhaps I could flash an update to TWRP which has fixed permissions? However I cannot access the Fastboot menu on my Y300: I can either get the recovery menu, the purple screen, or a freeze on the Huawei logo which shows up as "unauthorized device" when checking devices in cmd (the bootloader is unlocked).

All I would like to achieve is having CM running normally, allowing me to download a few apps from the Play Store.
Thank you for reading! Any advice is greatly appreciated, especially as I use this phone for work (luckily all this is happening over my Christmas leave!).