Default App error downloading from the play store

I'm having an issue downloading games form the game store it will download install and when I open the game it will say I need to download additional file because the download was corrupted. I've tried over and over to reinstall the game game and redownload everything just to get the same error. Using file explorer the file is there. Idk why it keeps saying corrupted .I'm on 4.4.2 cm nightly 12-20 using the dpk kernel Picts attached of said error after the game offers to download missing files.


Edit: to get some questions answered before they are asked. Tired on several WiFi and mobile connections. Games worked fine on stock and 4.1.2 wicked sensations. Why not update to latest nightly? tried that same result except no games and no video camera. I'm on 12 -20 clean install. Why no backups? I deleted the backups thinking they were corrupted because of this error. If I go into file system all game files are there just seem to be recognized as the game as corrupted. Puzzled

Sent from my SPH-L710 using xda app-developers app
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1387950142719.jpg
Views:	189
Size:	15.7 KB
ID:	2473484   Click image for larger version

Name:	uploadfromtaptalk1387950162993.jpg
Views:	200
Size:	16.8 KB
ID:	2473485