5,596,179 Members 34,056 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Can't disable shutter sound after 4.3 upgrade

Tip us?
 
bframe5
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Dec 2013
Camera [Q] Can't disable shutter sound after 4.3 upgrade

A strange and slightly annoying matter of fact, after I upgraded my C6802 to 4.3 I'm no longer able to disable the shutter sound in the default camera app. The menu/setting option is gone. Anyone else had the same problem?

My C6802 is the HK version, and I was able to disable it in 4.2.2.

I do live in Japan, and did upgrade while in Japan, but should that matter?
(I know that phones 'sold in Japan' aren't able to have their shutter sound disabled, but the Z Ultra isn't for sale in Japan, so in my opinion it shouldn't matter.)
 
kogepan
Old
#2  
kogepan's Avatar
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Oct 2006
Quote:
Originally Posted by bframe5 View Post
A strange and slightly annoying matter of fact, after I upgraded my C6802 to 4.3 I'm no longer able to disable the shutter sound in the default camera app. The menu/setting option is gone. Anyone else had the same problem?

My C6802 is the HK version, and I was able to disable it in 4.2.2.

I do live in Japan, and did upgrade while in Japan, but should that matter?
(I know that phones 'sold in Japan' aren't able to have their shutter sound disabled, but the Z Ultra isn't for sale in Japan, so in my opinion it shouldn't matter.)
Did you try to change regional setting to another country?
 
RyokoN
Old
(Last edited by RyokoN; 25th December 2013 at 12:32 PM.)
#3  
RyokoN's Avatar
Senior Member
Thanks Meter 512
Posts: 267
Join Date: Mar 2013

 
DONATE TO ME
If your ZU is rooted and Xposed framework installed, please try WedyMod-res.
Enable it and check "Don't force camera sound (カメラシャッター音設定を表示)", then reboot.
I only tested on Z1 4.3, but maybe the cause of this issue is same...
Sony added "force camera sound" settings in framework-res.apk for countries like Japan.
The Following User Says Thank You to RyokoN For This Useful Post: [ Click to Expand ]
 
kumeipark
Old
#4  
kumeipark's Avatar
Senior Member
Thanks Meter 23
Posts: 118
Join Date: Sep 2008
Location: Imphal
Quote:
Originally Posted by bframe5 View Post
A strange and slightly annoying matter of fact, after I upgraded my C6802 to 4.3 I'm no longer able to disable the shutter sound in the default camera app. The menu/setting option is gone. Anyone else had the same problem?

My C6802 is the HK version, and I was able to disable it in 4.2.2.

I do live in Japan, and did upgrade while in Japan, but should that matter?
(I know that phones 'sold in Japan' aren't able to have their shutter sound disabled, but the Z Ultra isn't for sale in Japan, so in my opinion it shouldn't matter.)
No problem with my C6802


Sent from my C6802 using Tapatalk
 
LordManhattan
Old
#5  
LordManhattan's Avatar
Senior Member
Thanks Meter 5430
Posts: 14,498
Join Date: Oct 2007
Location: Kepler-34b
I also have the option to disable it on my 6833.
 
I DO NOT RUN A SUPPORT LINE THROUGH PERSONAL MESSAGES,
SO PLEASE DO NOT PM ME ABOUT HELP (*COUGH* UNLESS I KNOW YOU *COUGH*).

THANK YOU, AND PLEASE HAVE A COOKIE ON YOUR WAY OUT.


 
mknewman
Old
#6  
Senior Member
Thanks Meter 53
Posts: 614
Join Date: Dec 2006
Location: Houston, Tx

 
DONATE TO ME
Its on my c6833 also. Is it a US version thing that prevents it?

Sent from my C6833 using xda app-developers app
 
RyokoN
Old
#7  
RyokoN's Avatar
Senior Member
Thanks Meter 512
Posts: 267
Join Date: Mar 2013

 
DONATE TO ME
Decompile framework-res.apk and find "values-mcc440" in res folder.
mcc440 means "Mobile country code - Japan" and it contains bools.xml.
Contents are
Code:
<?xml version="1.0" encoding="utf-8"?>
<resources>
    <bool name="config_camera_sound_forced">true</bool>
</resources>
and this bool disables shutter sound option.
If you inserts Japanese SIM card, this bool is automatically loaded.

If your SIM is for countries not restricting muted shutter sound or you don't insert SIM, option is still there.
The Following User Says Thank You to RyokoN For This Useful Post: [ Click to Expand ]
 
bframe5
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Dec 2013
Quote:
Originally Posted by RyokoN View Post
If your ZU is rooted and Xposed framework installed, please try WedyMod-res.
Enable it and check "Don't force camera sound (カメラシャッター音設定を表示)", then reboot.
I only tested on Z1 4.3, but maybe the cause of this issue is same...
Sony added "force camera sound" settings in framework-res.apk for countries like Japan.
(Sorry for the delay, was quite busy over the holidays...)
Thanks! Worked like a charm.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...