Default Framaroot nit working on my Galaxy NoteII N7100 running Jelly bean 4.3

Hey there i am using samsung galaxy note 2 model number n 7100 which is running android jellybean version 4.3latest versions, when i tried to install ☆FRAMROOT☆ V 1.8 on my note 2 it did not work the build number of my note 2 is N7100XXUEMKD.

I also tried to ROOT my phone through pc with cf auto root and other options available but it didn't route properly. Super user installed but then the knox on my note 2 shows a security warning and security the policy update message and the super user stopped unfortunately message appears so this also didn't work.

I also installed the "supersu" [v 1.86] app from chainfire, but it shows the following message:

Click image for larger version

Name:	uploadfromtaptalk1388035434529.jpg
Views:	1261
Size:	25.4 KB
ID:	2475021

I don't want to root my phone through pc, is there any other version of ☆FRAMROOT☆ available that could work on my note 2 jellybean 4.3.

Please help me guys !!!!