5,600,919 Members 41,539 Now Online
XDA Developers Android and Mobile Development Forum

Horrible lag after running Super Hexagon

Tip us?
 
Eregoth
Old
(Last edited by Eregoth; 15th December 2013 at 11:30 PM.)
#1  
Eregoth's Avatar
Member - OP
Thanks Meter 35
Posts: 56
Join Date: May 2013
Exclamation Horrible lag after running Super Hexagon

Sometimes when I launch Super Hexagon, the game runs terribly slow. It feels like it's running at 15-20 FPS instead of 60 FPS. The weird part is that this lag persists after I exit the game. The whole system becomes super slow with choppy animations.

I've tried killing the app and even clearing the data, but the only thing that seems to fix this is a reboot. I can reproduce this behavior after rebooting again. It usually happens on the 2nd or 3rd time I launch the app, but sometimes it can take up to 10 times of closing and launching. Holding the tablet vertically seems to trigger it faster (although I'm not completely sure if it's related yet).

I'm running completely stock KOT49H and version 1.0.5 of Super Hexagon.
I haven't been able to reproduce this on my Nexus 4 or my old Nexus 7 (2012).

Can anyone else confirm that this happens on their Nexus 7 (2013)? I'm just wondering if it's a bug/compatibility issue or if it's a problem with my device
 
Eregoth
Old
#2  
Eregoth's Avatar
Member - OP
Thanks Meter 35
Posts: 56
Join Date: May 2013
Just a quick update: Tried changing to ART with and flashing the latest franco kernel (just to experiment), and it still happens in the exact same way
 
chiefz0r
Old
#3  
Junior Member
Thanks Meter 0
Posts: 17
Join Date: Dec 2009
Quote:
Originally Posted by Eregoth View Post
Just a quick update: Tried changing to ART with and flashing the latest franco kernel (just to experiment), and it still happens in the exact same way
I know this is a late response but I had the same thing happen to me twice tonight and I found your thread while googling for the issue myself.

Force closing the app doesn't help. It seems I have to reboot to fix it.

Have you by any chance figured out a fix? I'm running a 2013 n7 completely stock
 
Eregoth
Old
#4  
Eregoth's Avatar
Member - OP
Thanks Meter 35
Posts: 56
Join Date: May 2013
Quote:
Originally Posted by chiefz0r View Post
I know this is a late response but I had the same thing happen to me twice tonight and I found your thread while googling for the issue myself.

Force closing the app doesn't help. It seems I have to reboot to fix it.

Have you by any chance figured out a fix? I'm running a 2013 n7 completely stock
Haven't found a fix yet
It's clearly a software issue though, either with the game or the latest N7 2013 build. Maybe someone who's more skilled could check the debug log (or something) to figure out the cause.
 
NsZebra
Old
(Last edited by NsZebra; 25th December 2013 at 07:10 PM.)
#5  
NsZebra's Avatar
Senior Member
Thanks Meter 458
Posts: 514
Join Date: Dec 2012
Location: Buenos Aires

 
DONATE TO ME
Default Hey

EDIT:

to fix this problem, open your favorite file explorer..

navigate through android/data/(superhexagon package file name)

go to settings.dat

change vsync from 1 to 0

Check out my Youtube Channel

 
Device: Nexus 7 (2013) (Locked) Wi-Fi
The Following User Says Thank You to NsZebra For This Useful Post: [ Click to Expand ]
 
Eregoth
Old
#6  
Eregoth's Avatar
Member - OP
Thanks Meter 35
Posts: 56
Join Date: May 2013
Quote:
Originally Posted by NsZebra View Post
EDIT:

to fix this problem, open your favorite file explorer..

navigate through android/data/(superhexagon package file name)

go to settings.dat

change vsync from 1 to 0
Just tried this and it happend again (on the first try). Rebooted and triggered it again after launching the app 3 times.
 
NeXuS7_uSeR
Old
#7  
Junior Member
Thanks Meter 1
Posts: 12
Join Date: Dec 2013
Quote:
Originally Posted by Eregoth View Post
Sometimes when I launch Super Hexagon, the game runs terribly slow. It feels like it's running at 15-20 FPS instead of 60 FPS. The weird part is that this lag persists after I exit the game. The whole system becomes super slow with choppy animations.

I've tried killing the app and even clearing the data, but the only thing that seems to fix this is a reboot. I can reproduce this behavior after rebooting again. It usually happens on the 2nd or 3rd time I launch the app, but sometimes it can take up to 10 times of closing and launching. Holding the tablet vertically seems to trigger it faster (although I'm not completely sure if it's related yet).

I'm running completely stock KOT49H and version 1.0.5 of Super Hexagon.
I haven't been able to reproduce this on my Nexus 4 or my old Nexus 7 (2012).

Can anyone else confirm that this happens on their Nexus 7 (2013)? I'm just wondering if it's a bug/compatibility issue or if it's a problem with my device
I confirm, the only solution is to reboot... Very annoying if it happens while you break a record

Tags
lag, low fps, nexus 7 2013, stutter, super hexagon
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...