5,600,612 Members 34,044 Now Online
XDA Developers Android and Mobile Development Forum

[HELP] EVO 4G LTE Touch screen won't work

Tip us?
 
den_piero
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 21
Join Date: Feb 2010
Default [HELP] EVO 4G LTE Touch screen won't work

Hi Guys,

I need help. I really appreciate if someone could help me.

Current Evo 4G LTE
Running Rom : Meanbean 2.71
baseband 1.12.11.0809
build 3.15.651.16.cl124461
kernel 3.4.10
HBoot 1.19
Radio 1.12
S ON,Unlocked
TWRP 2.3.1

My touchscreen won't work. Sometimes it's respond, but most of the time it's not respond. I have tried to upgrade TWRP 2.6x to see if i have update the touchpanel driver (but i think i have not update anything, just incase) still doesn't work. I have downgrade the touchpanel in Capt Throwback post, still not working. Is my panel or digitizer borked?

I thought in first place it was software issue, i have uninstall most added app, but not helping (doing it while the touchpanel work, tiba backup, nandroid backup also). but now I can't even flash anything since the touchpanel in TWRP also not responding. Does it related to power? since my batt drain so fast at this time.

Is there a way to flash ROM from fastboot/adb? just to make sure i have clean install, and see if the touchpanel related to software or hardware problem.

Please help.
 
FinZ28
Old
#2  
FinZ28's Avatar
Recognized Contributor
Thanks Meter 1608
Posts: 3,085
Join Date: Jul 2012
Location: Birmingham, AL

 
DONATE TO ME
You're software is really out of date. Having said that, it would appear that you are still on the older TP driver. If your screen works intermittently, your issue is most likely hardware-related.

Sent from my HTC EVO 4G LTE
 
den_piero
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 21
Join Date: Feb 2010
Quote:
Originally Posted by FinZ28 View Post
You're software is really out of date. Having said that, it would appear that you are still on the older TP driver. If your screen works intermittently, your issue is most likely hardware-related.

Sent from my HTC EVO 4G LTE
I see. It's kindda sad since i love this phone that is why i haven't change to another. Yes it's outdated, since i haven't got time to play with it.

Is it possibly the digitizer?
 
RobertBohannon
Old
#4  
RobertBohannon's Avatar
Senior Member
Thanks Meter 22
Posts: 137
Join Date: Apr 2012
Location: Baytown
Yea I am experiencing a similar thing over here mine however, will work fine then the screen recognizes random "ghost" touches and I have to lock then unlock the phone to make it quit. I'm hoping it's just the digitizer.

Sent from my EVO using xda app-developers app
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes